Commit 4511ae31 authored by Simon McVittie's avatar Simon McVittie Committed by Vivek Das Mohapatra

Add some notes on building from git on older host systems

Signed-off-by: Simon McVittie's avatarSimon McVittie <smcv@collabora.com>
parent 0565882c
......@@ -467,6 +467,7 @@ EXTRA_DIST += autogen.sh
EXTRA_DIST += build-aux/git-version-gen
EXTRA_DIST += ci/Jenkinsfile
EXTRA_DIST += data/capsule-mkstublib
EXTRA_DIST += doc/Building-libcapsule.txt
EXTRA_DIST += doc/Strategy.txt
EXTRA_DIST += doc/capsule-init-project.xml
EXTRA_DIST += doc/capsule-mkstublib.xml
......
Building libcapsule from git requires GNU autoconf-archive macros. The
oldest supported version is 20180313-1 from Debian 9 'stretch'. If your
development system or container is older, unpack or clone a suitable
version of autoconf-archive and use commands like:
libcapsule$ ACLOCAL_PATH=/path/to/autoconf-archive/m4 NOCONFIGURE=1 ./autogen.sh
libcapsule$ ./configure
libcapsule$ make
Building from tarball releases removes this requirement.
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment