Commit 712c625b authored by Tim-Philipp Müller's avatar Tim-Philipp Müller

configure.ac: Bump Gtk+ requirement to 2.12.0 for gtk_range_set_fill_level...

configure.ac: Bump Gtk+ requirement to 2.12.0 for gtk_range_set_fill_level (NB: this only affects compilation of some...

Original commit message from CVS:
* configure.ac:
Bump Gtk+ requirement to 2.12.0 for gtk_range_set_fill_level
(NB: this only affects compilation of some of the examples).
Remove some configure.ac cruft that's not needed any longer.
parent 9e630c23
2008-04-18 Tim-Philipp Müller <tim at centricular dot net>
* configure.ac:
Bump Gtk+ requirement to 2.12.0 for gtk_range_set_fill_level
(NB: this only affects compilation of some of the examples).
Remove some configure.ac cruft that's not needed any longer.
2008-04-18 Edward Hervey <edward.hervey@collabora.co.uk>
* gst/gdp/gstgdpdepay.c: (gst_gdp_depay_chain):
......@@ -266,26 +266,8 @@ GST_PREFIX="`$PKG_CONFIG --variable=prefix gstreamer-$GST_MAJORMINOR`"
AC_SUBST(GLIB_PREFIX)
AC_SUBST(GST_PREFIX)
dnl GTK is optional and used in examples
HAVE_GTK=NO
PKG_CHECK_MODULES(GTK2, gtk+-2.0 >= 2.2.0, HAVE_GTK_22=yes, HAVE_GTK_22=no)
if test "x$HAVE_GTK_22" = "xyes"; then
HAVE_GTK=yes
GTK_VERSION=`$PKG_CONFIG --variable=gtk_binary_version gtk+-2.0`
AC_SUBST(GTK_VERSION)
GTK_PREFIX=`$PKG_CONFIG --variable=prefix gdk-pixbuf-2.0`
AC_SUBST(GTK_BASE_DIR)
else
PKG_CHECK_MODULES(GTK2, gtk+-2.0, HAVE_GTK_20=yes, HAVE_GTK_20=no)
fi
if test "x$HAVE_GTK_20" = "xyes"; then
HAVE_GTK=yes
fi
GTK_CFLAGS=$GTK2_CFLAGS
GTK_LIBS=$GTK2_LIBS
AC_SUBST(GTK_LIBS)
AC_SUBST(GTK_CFLAGS)
AC_SUBST(HAVE_GTK)
dnl GTK is optional and only used in examples
PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.12.0, HAVE_GTK=yes, HAVE_GTK=no)
AM_CONDITIONAL(HAVE_GTK, test "x$HAVE_GTK" = "xyes")
dnl *** set variables based on configure arguments ***
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment