Commit d4d1ae95 authored by Tim-Philipp Müller's avatar Tim-Philipp Müller
Browse files

pkgconfig: only install gstreamer-gl-1.0.pc if OpenGL support was built

https://bugzilla.gnome.org/show_bug.cgi?id=793039
parent 0d14819e
......@@ -11,7 +11,6 @@ pcverfiles = \
gstreamer-sdp-@GST_API_VERSION@.pc \
gstreamer-tag-@GST_API_VERSION@.pc \
gstreamer-video-@GST_API_VERSION@.pc \
gstreamer-gl-@GST_API_VERSION@.pc \
gstreamer-plugins-base-@GST_API_VERSION@.pc
pcverfiles_uninstalled = \
gstreamer-allocators-@GST_API_VERSION@-uninstalled.pc \
......@@ -25,9 +24,13 @@ pcverfiles_uninstalled = \
gstreamer-sdp-@GST_API_VERSION@-uninstalled.pc \
gstreamer-tag-@GST_API_VERSION@-uninstalled.pc \
gstreamer-video-@GST_API_VERSION@-uninstalled.pc \
gstreamer-gl-@GST_API_VERSION@-uninstalled.pc \
gstreamer-plugins-base-@GST_API_VERSION@-uninstalled.pc
if HAVE_GST_GL
pcverfiles += gstreamer-gl-@GST_API_VERSION@.pc
pcverfiles_uninstalled += gstreamer-gl-@GST_API_VERSION@-uninstalled.pc
endif
all-local: $(pcverfiles) $(pcverfiles_uninstalled)
cp_verbose = $(cp_verbose_$(V))
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment