Commit f6520ee9 authored by Sebastian Dröge's avatar Sebastian Dröge

pkg-config: Add orc-0.4 to Requires.private of gstreamer-audio and gstreamer-video

https://bugzilla.gnome.org/show_bug.cgi?id=794307
parent abcb96b6
......@@ -280,6 +280,13 @@ AG_GST_GLIB_CHECK([$GLIB_REQ])
ORC_CHECK([0.4.24])
dnl For Requires.private in pkg-config files
ORC_PC=
if test x"$HAVE_ORC" = "xyes"; then
ORC_PC="orc-0.4"
fi
AC_SUBST(ORC_PC)
dnl checks for gstreamer
dnl uninstalled is selected preferentially -- see pkg-config(1)
AG_GST_CHECK_GST($GST_API_VERSION, [$GST_REQ], yes)
......
......@@ -11,6 +11,7 @@ Name: GStreamer Audio Library, Uninstalled
Description: Audio helper functions and base classes, uninstalled
Version: @VERSION@
Requires: gstreamer-@GST_API_VERSION@ gstreamer-base-@GST_API_VERSION@
Requires.private: @ORC_PC@
Libs: -L${libdir} -lgstaudio-@GST_API_VERSION@
Cflags: -I@abs_top_srcdir@/gst-libs -I@abs_top_builddir@/gst-libs
......@@ -10,6 +10,7 @@ typelibdir=${libdir}/girepository-1.0
Name: GStreamer Audio library
Description: Audio helper functions and base classes
Requires: gstreamer-@GST_API_VERSION@ gstreamer-base-@GST_API_VERSION@
Requires.private: @ORC_PC@
Version: @VERSION@
Libs: -L${libdir} -lgstaudio-@GST_API_VERSION@
Cflags: -I${includedir}
......
......@@ -11,6 +11,7 @@ Name: GStreamer Video Library, Uninstalled
Description: Video base classes and helper functions, uninstalled
Version: @VERSION@
Requires: gstreamer-@GST_API_VERSION@ gstreamer-base-@GST_API_VERSION@
Requires.private: @ORC_PC@
Libs: -L${libdir} -lgstvideo-@GST_API_VERSION@
Cflags: -I@abs_top_srcdir@/gst-libs -I@abs_top_builddir@/gst-libs
......@@ -10,6 +10,7 @@ typelibdir=${libdir}/girepository-1.0
Name: GStreamer Video Library
Description: Video base classes and helper functions
Requires: gstreamer-@GST_API_VERSION@ gstreamer-base-@GST_API_VERSION@
Requires.private: @ORC_PC@
Version: @VERSION@
Libs: -L${libdir} -lgstvideo-@GST_API_VERSION@
Cflags: -I${includedir}
......
......@@ -7,6 +7,7 @@ pkgconf.set('includedir', '${prefix}/@0@'.format(get_option('includedir')))
pkgconf.set('GST_API_VERSION', api_version)
pkgconf.set('VERSION', gst_version)
pkgconf.set('LIBM', libm.found() ? '-lm' : '')
pkgconf.set('ORC_PC', have_orcc ? 'orc-0.4' : '')
# needed for generating -uninstalled.pc files
pkgconf.set('abs_top_builddir', join_paths(meson.current_build_dir(), '..'))
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment