Commit 11a8aa91 authored by Tim-Philipp Müller's avatar Tim-Philipp Müller

flac: require a 'newer' flac and remove support for the legacy flac API

parent fd18185d
......@@ -697,7 +697,7 @@ AG_GST_CHECK_FEATURE(ESD, [ESounD sound daemon], esdsink, [
dnl *** FLAC ***
translit(dnm, m, l) AM_CONDITIONAL(USE_FLAC, true)
AG_GST_CHECK_FEATURE(FLAC, [FLAC lossless audio], flac, [
AG_GST_PKG_CHECK_MODULES(FLAC, flac >= 1.1.3)
AG_GST_PKG_CHECK_MODULES(FLAC, flac >= 1.1.4)
])
dnl *** GConf ***
......
......@@ -660,7 +660,6 @@ GST_FLAC_DEC_CLASS
GST_IS_FLAC_DEC
GST_IS_FLAC_DEC_CLASS
gst_flac_dec_get_type
LEGACY_FLAC
</SECTION>
<SECTION>
......
This diff is collapsed.
......@@ -27,12 +27,6 @@
#include <FLAC/all.h>
#if !defined(FLAC_API_VERSION_CURRENT) || FLAC_API_VERSION_CURRENT < 8
#define LEGACY_FLAC
#else
#undef LEGACY_FLAC
#endif
G_BEGIN_DECLS
#define GST_TYPE_FLAC_DEC gst_flac_dec_get_type()
......
This diff is collapsed.
......@@ -25,12 +25,6 @@
#include <FLAC/all.h>
#if !defined(FLAC_API_VERSION_CURRENT) || FLAC_API_VERSION_CURRENT < 8
#define LEGACY_FLAC
#else
#undef LEGACY_FLAC
#endif
G_BEGIN_DECLS
#define GST_TYPE_FLAC_ENC (gst_flac_enc_get_type())
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment