Commit 3a7c7705 authored by Thomas Vander Stichele's avatar Thomas Vander Stichele
Browse files

various spec fixes

Original commit message from CVS:
various spec fixes
parent 7ebd7b97
# This SPEC file is created in a way that tries to solve various demands.
# First of all it tries to create packages that will easily replace both the
# Fedora Core default packages and also replace the extra rpms provided
# by Fedora.us or freshrpms.net.
# At the same time they will only include plugins for which you have the needed
# packages installed at the time you run autogen.sh. This means that if you
# are not careful you might end up with less plugins than what the standard
# packages provide, which in turn means things might stop working for you.
# So make sure you have an idea of what you do before creating RPMS using this
# SPEC file.
%define register %{_bindir}/gst-register-%{majorminor} > /dev/null 2>&1 || :
%define gst_minver 0.7.6
%define gstp_minver 0.7.6
Name: gstreamer09-plugins-good
%define majorminor @GST_MAJORMINOR@
%define gstreamer gstreamer09
%define gstregister %{_bindir}/gst-register-%{majorminor}
%define register %{gstregister} > /dev/null 2>&1 || :
%define gst_minver 0.9.1
Name: %{gstreamer}-plugins-good
Version: @VERSION@
Release: @GST_PLUGINS_VERSION_RELEASE@
Release: @GST_PLUGINS_GOOD_VERSION_RELEASE@.gst
Summary: GStreamer plug-ins with good code and licensing
%define majorminor @GST_MAJORMINOR@
Group: Applications/Multimedia
License: LGPL
URL: http://gstreamer.net/
Vendor: GStreamer Backpackers Team <package@gstreamer.net>
Source: http://gstreamer.freedesktop.org/src/gst-plugins/gst-plugins-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-root
URL: http://gstreamer.freedesktop.org/
Vendor: GStreamer Backpackers Team <package@gstreamer.freedesktop.org>
Source: http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%define _glib2 @GLIB2_REQ@
Requires: %{gstreamer} >= %{gst_minver}
BuildRequires: %{gstreamer}-devel >= %{gst_minver}
Requires(post): %{gstregister}
Requires(postun): %{gstregister}
Requires: glib2 >= %_glib2
BuildRequires: glib2-devel >= %_glib2
Requires: gstreamer09 >= %{gst_minver}
BuildRequires: gstreamer09-devel >= %{gst_minver}
BuildRequires: gcc-c++
BuildRequires: XFree86-devel
# @USE_AUDIOFILE_TRUE@Requires: audiofile >= 0.2.1
# @USE_AUDIOFILE_TRUE@BuildRequires: audiofile-devel >= 0.2.1
# @USE_CDPARANOIA_TRUE@Requires: cdparanoia-libs >= alpha9.7
# @USE_CDPARANOIA_TRUE@BuildRequires: cdparanoia-devel >= alpha9.7
@USE_ESD_TRUE@Requires: esound >= 0.2.8
@USE_ESD_TRUE@BuildRequires: esound-devel >= 0.2.8
@USE_ESD_TRUE@Obsoletes: gstreamer-esd
......@@ -50,10 +34,6 @@ BuildRequires: XFree86-devel
@USE_FLAC_TRUE@BuildRequires: flac-devel >= 1.0.3
@USE_GCONF_TRUE@Requires: GConf2
@USE_GCONF_TRUE@BuildRequires: GConf2-devel
# @USE_GNOME_VFS_TRUE@Requires: gnome-vfs2 > 1.9.4.00
# @USE_GNOME_VFS_TRUE@BuildRequires: gnome-vfs2-devel > 1.9.4.00
# @USE_HERMES_TRUE@Requires: Hermes >= 1.3.0
# @USE_HERMES_TRUE@BuildRequires: Hermes-devel >= 1.3.0
@USE_JPEG_TRUE@Requires: libjpeg
@USE_JPEG_TRUE@BuildRequires: libjpeg-devel
@USE_LIBPNG_TRUE@Requires: libpng >= 1.2.0
......@@ -65,25 +45,16 @@ BuildRequires: XFree86-devel
# @USE_PANGO_TRUE@BuildRequires: pango-devel
# @USE_RAW1394_TRUE@Requires: libraw1394
# @USE_RAW1394_TRUE@BuildRequires: libraw1394-devel
# @USE_SDL_TRUE@Requires: SDL >= 1.2.0
# @USE_SDL_TRUE@BuildRequires: SDL-devel >= 1.2.0
# @USE_SDL_TRUE@#SDL-devel should require XFree86-devel because it links to it
# @USE_SDL_TRUE@#only it doesn't seem to do that currently
# @USE_SDL_TRUE@BuildRequires: XFree86-devel
@USE_SPEEX_TRUE@Requires: speex
@USE_SPEEX_TRUE@BuildRequires: speex-devel
# @USE_SMOOTHWAVE_TRUE@Requires: gtk2
# @USE_SMOOTHWAVE_TRUE@BuildRequires: gtk2-devel
# @USE_VORBIS_TRUE@Requires: libogg >= 1.0
# @USE_VORBIS_TRUE@Requires: libvorbis >= 1.0
# @USE_VORBIS_TRUE@BuildRequires: libogg-devel >= 1.0
# @USE_VORBIS_TRUE@BuildRequires: libvorbis-devel >= 1.0
# @USE_XVIDEO_TRUE@Requires: XFree86-libs
# @USE_XVIDEO_TRUE@BuildRequires: XFree86-devel
# @USE_HERMES_TRUE@# @USE_LIBPNG_TRUE@Requires: libpng
@USE_SHOUT2_TRUE@BuildRequires: libshout-devel >= 2.0
# @USE_LADSPA_TRUE@BuildRequires: ladspa-devel
@USE_AALIB_TRUE@BuildRequires: aalib-devel >= 1.3
@USE_AALIB_TRUE@Provides: gstreamer-aasink = %{version}-%{release}
%description
GStreamer is a streaming-media framework, based on graphs of filters which
GStreamer is a streaming media framework, based on graphs of filters which
operate on media data. Applications using this library can do anything
from real-time sound processing to playing videos, and just about anything
else media-related. Its plugin-based architecture means that new data
......@@ -91,10 +62,9 @@ types or processing capabilities can be added simply by installing new
plug-ins.
%prep
%setup -n gst-plugins-%{version}
%setup -q -n gst-plugins-good-%{version}
%build
%configure \
--with-gdk-pixbuf-loader-dir=$RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.2.0/loaders \
--enable-debug \
--enable-DEBUG
......@@ -114,410 +84,73 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{majorminor}/libgstgdkpixbuf.so
%find_lang gst-plugins-good-%{majorminor}
%clean
rm -rf $RPM_BUILD_ROOT
%files
%files -f gst-plugins-good-%{majorminor}.lang
%defattr(-, root, root)
%doc AUTHORS COPYING README REQUIREMENTS
# non-core plugins without external dependencies
%{_libdir}/gstreamer-%{majorminor}/libgstalaw.so
%{_libdir}/gstreamer-%{majorminor}/libgstalpha.so
%{_libdir}/gstreamer-%{majorminor}/libgstautodetect.so
%{_libdir}/gstreamer-%{majorminor}/libgstavi.so
%{_libdir}/gstreamer-%{majorminor}/libgsteffectv.so
%{_libdir}/gstreamer-%{majorminor}/libgstfdsrc.so
%{_libdir}/gstreamer-%{majorminor}/libgstgoom.so
%{_libdir}/gstreamer-%{majorminor}/libgstlevel.so
%{_libdir}/gstreamer-%{majorminor}/libgstmulaw.so
%{_libdir}/gstreamer-%{majorminor}/libgstsmpte.so
%{_libdir}/gstreamer-%{majorminor}/libgstrtp.so
%{_libdir}/gstreamer-%{majorminor}/libgstrtsp.so
%{_libdir}/gstreamer-%{majorminor}/libgstsmpte.so
# %{_libdir}/gstreamer-%{majorminor}/libgsttcp.so
%{_libdir}/gstreamer-%{majorminor}/libgstudp.so
%{_libdir}/gstreamer-%{majorminor}/libgstalpha.so
%{_libdir}/gstreamer-%{majorminor}/libgstgoom.so
%{_libdir}/gstreamer-%{majorminor}/libgstrmdemux.so
%{_libdir}/gstreamer-%{majorminor}/libgstavi.so
%{_libdir}/gstreamer-%{majorminor}/libgstlevel.so
%{_libdir}/gstreamer-%{majorminor}/libgstvideobox.so
%{_libdir}/gstreamer-%{majorminor}/libgstfdsrc.so
%{_libdir}/gstreamer-%{majorminor}/libgstwavparse.so
%{_libdir}/gstreamer-%{majorminor}/libgstautodetect.so
%{_libdir}/gstreamer-%{majorminor}/libgstsilence.so
%{_libdir}/gstreamer-%{majorminor}/libgstvideoflip.so
%{_libdir}/gstreamer-%{majorminor}/libgstqtdemux.so
%{_libdir}/gstreamer-%{majorminor}//libgstmpegaudioparse.so
%{_libdir}/gstreamer-%{majorminor}/libgstwavenc.so
%{_libdir}/gstreamer-%{majorminor}/libgstwavparse.so
# gstreamer-plugins with external dependencies but in the main package
# @USE_ARTS_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstarts.so
# @USE_ARTSC_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstartsdsink.so
# @USE_AUDIOFILE_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstaudiofile.so
# @USE_CDPARANOIA_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstcdparanoia.so
@USE_LIBCACA_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstcacasink.so
@USE_ESD_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstesd.so
# @USE_POLYP_TRUE@%{_libdir}/gstreamer-%{majorminor}/libpolypaudio.so
@USE_FLAC_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstflac.so
# @USE_HERMES_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgsthermescolorspace.so
# @USE_SMOOTHWAVE_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstsmoothwave.so
@USE_JPEG_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstjpeg.so
# @USE_MIKMOD_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstmikmod.so
# @USE_SDL_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstsdlvideosink.so
# @USE_VORBIS_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstvorbis.so
# @USE_VORBIS_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstogg.so
@USE_LIBPNG_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstpng.so
@USE_OSS_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstossaudio.so
# @USE_GST_V4L_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstvideo4linux.so
## @USE_RAW1394_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgst1394.so
# Snapshot plugin uses libpng
# @USE_LIBPNG_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstsnapshot.so
# @USE_PANGO_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgsttextoverlay.so
# @USE_PANGO_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgsttimeoverlay.so
@USE_SPEEX_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstspeex.so
@USE_LIBCACA_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstcacasink.so
# @USE_XVIDEO_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstximagesink.so
# @USE_XVIDEO_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstxvimagesink.so
# @USE_SNDFILE_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstsndfile.so
# @USE_MUSICBRAINZ_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgsttrm.so
@USE_GCONF_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstgconfelements.so
## Libraries
%{_libdir}/libgstvideofilter-%{majorminor}.*
%{_datadir}/locale
%post
%{_bindir}/gst-register-%{majorminor} > /dev/null 2> /dev/null
%package audio
Summary: Additional audio plugins for GStreamer
Group: Applications/Multimedia
@USE_SIDPLAY_TRUE@BuildRequires: libsidplay-devel >= 1.36.0
# @USE_SHOUT_TRUE@BuildRequires: libshout-devel <= 2.0
# # @USE_SHOUT2_TRUE@BuildRequires: libshout-devel >= 2.0
# @USE_LADSPA_TRUE@BuildRequires: ladspa-devel
Requires: gstreamer09-plugins >= %{gstp_minver}
Requires(pre): %{_bindir}/gst-register-%{majorminor}
Requires(post): %{_bindir}/gst-register-%{majorminor}
# @USE_LADSPA_TRUE@Provides: gstreamer-ladspa = %{version}-%{release}
@USE_SIDPLAY_TRUE@Provides: gstreamer-sid = %{version}-%{release}
# @USE_SHOUT_TRUE@Provides: gstreamer-shout = %{version}-%{release}
%description audio
This package contains additional audio plugins for GStreamer, including
- codec for sid (C64)
- a shout element to stream to icecast servers
- a ladspa elements wrapping LADSPA plugins
# - a shout 2 element
%files audio
%defattr(-, root, root, -)
# @USE_LADSPA_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstladspa.so
@USE_SIDPLAY_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstsid.so
# @USE_SHOUT_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstshout.so
# # @USE_SHOUT2_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstshout2.so
%post audio
%{register}
%postun audio
%{register}
%package extra-audio
Summary: Extra audio plugins for GStreamer
Group: Applications/Multimedia
@USE_FAAD_TRUE@BuildRequires: faad2-devel >= 2.0
# @USE_GSM_TRUE@BuildRequires: gsm-devel >= 1.0.10
@USE_LAME_TRUE@BuildRequires: lame-devel >= 3.89
@USE_MAD_TRUE@BuildRequires: libid3tag-devel >= 0.15.0
@USE_MAD_TRUE@BuildRequires: libmad-devel >= 0.15.0
Requires: gstreamer09-plugins >= %{gstp_minver}
Requires(pre): %{_bindir}/gst-register-%{majorminor}
Requires(post): %{_bindir}/gst-register-%{majorminor}
@USE_FAAD_TRUE@Provides: gstreamer-faad = %{version}-%{release}
# @USE_GSM_TRUE@Provides: gstreamer-gsm = %{version}-%{release}
@USE_LAME_TRUE@Provides: gstreamer-lame = %{version}-%{release}
@USE_MAD_TRUE@Provides: gstreamer-mad = %{version}-%{release}
%description extra-audio
This package contains extra audio plugins for GStreamer, including
- gsm decoding
- faad2 decoding
- mad mp3 decoding
- lame mp3 encoding
%post extra-audio
%{register}
%postun extra-audio
%{register}
%files extra-audio
%defattr(-, root, root, -)
@USE_FAAD_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstfaad.so
# @USE_GSM_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstgsm.so
@USE_LAME_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstlame.so
@USE_MAD_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstmad.so
%package extra-dvd
Summary: DVD plugins for GStreamer
Group: Applications/Multimedia
# @USE_A52DEC_TRUE@BuildRequires: a52dec-devel >= 0.7.3
# @USE_DVDNAV_TRUE@BuildRequires: libdvdnav-devel >= 0.1.3
# @USE_DVDREAD_TRUE@BuildRequires: libdvdread-devel >= 0.9.0
Requires: gstreamer09-plugins >= %{gstp_minver}
Requires: gstreamer09-plugins-extra-video >= %{gstp_minver}
Requires(pre): %{_bindir}/gst-register-%{majorminor}
Requires(post): %{_bindir}/gst-register-%{majorminor}
Provides: gstreamer-dvd = %{version}-%{release}
# @USE_A52DEC_TRUE@Provides: gstreamer- = %{version}-%{release}
# @USE_DVDNAV_TRUE@Provides: gstreamer-dvdnavsrc = %{version}-%{release}
# @USE_DVDREAD_TRUE@Provides: gstreamer-dvdreadsrc = %{version}-%{release}
%description extra-dvd
This package contains dvd plugins for GStreamer, including
- libdvdread
decoding
%post extra-dvd
%{register}
%postun extra-dvd
%{register}
%files extra-dvd
%defattr(-, root, root, -)
# @USE_A52DEC_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgsta52dec.so
# @USE_DVDNAV_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstdvdnavsrc.so
# @USE_DVDREAD_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstdvdreadsrc.so
%package video
Summary: Additional video plugins for GStreamer
Group: Applications/Multimedia
@USE_AALIB_TRUE@BuildRequires: aalib-devel >= 1.3
Requires: gstreamer09-plugins >= %{gstp_minver}
Requires(pre): %{_bindir}/gst-register-%{majorminor}
Requires(post): %{_bindir}/gst-register-%{majorminor}
@USE_AALIB_TRUE@Provides: gstreamer-aasink = %{version}-%{release}
%description video
This package contains additional video plugins for GStreamer, including
- an output sink based on aalib (ASCII art output)
- an element for decoding dv streams using libdv
- an output sink based on cacalib (color ASCII art output)
- A Dirac video format decoder
- An output sink based on OpenGL
%files video
%defattr(-, root, root, -)
@USE_SHOUT2_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstshout2.so
@USE_AALIB_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstaasink.so
@USE_LIBDV_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstdv.so
@USE_DV1394_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgst1394.so
@USE_LIBCACA_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstcacasink.so
# @USE_DIRAC_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstdirac.so
# @USE_OPENGL_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstglimagesink.so
%post video
%{register}
%postun video
%{register}
## Libraries
%{_libdir}/libgstvideofilter-%{majorminor}.*
%package extra-video
Summary: Extra video plugins for GStreamer
Group: Applications/Multimedia
# @USE_LIBFAME_TRUE@BuildRequires: libfame-devel >= 0.9.0
@USE_MPEG2DEC_TRUE@BuildRequires: mpeg2dec-devel >= 0.4.0
# @USE_SWFDEC_TRUE@BuildRequires: swfdec-devel
Requires: gstreamer09-plugins >= %{gstp_minver}
Requires: gstreamer09-plugins-extra-audio >= %{gstp_minver}
Requires(pre): %{_bindir}/gst-register-%{majorminor}
Requires(post): %{_bindir}/gst-register-%{majorminor}
# @USE_LIBFAME_TRUE@Provides: gstreamer-libfame = %{version}-%{release}
@USE_MPEG2DEC_TRUE@Provides: gstreamer-mpeg2dec = %{version}-%{release}
# @USE_SWFDEC_TRUE@Provides: gstreamer-swfdec = %{version}-%{release}
%description extra-video
This package contains extra video plugins for GStreamer, including
- libfame MPEG video encoding
- mpeg2dec MPEG-2 decoding
- swfdec Flash decoding
%post extra-video
%{register}
%postun extra-video
%{register}
%files extra-video
%defattr(-, root, root, -)
# @USE_LIBFAME_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstlibfame.so
@USE_MPEG2DEC_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstmpeg2dec.so
# @USE_SWFDEC_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstswfdec.so
# Here are packages not in the base plugins package but not dependant
# on an external lib
# Here are all the packages depending on external libs #
## DXR3 ###
# @USE_DXR3_TRUE@%package -n gstreamer-plugins-dxr3
# @USE_DXR3_TRUE@Summary: GStreamer plug-in for playback using dxr3 card.
# @USE_DXR3_TRUE@Group: Applications/Multimedia
# @USE_DXR3_TRUE@Requires: gstreamer-plugins = %{version}
# @USE_DXR3_TRUE@Requires: em8300 >= 0.12.0
# @USE_DXR3_TRUE@BuildRequires: em8300-devel >= 0.12.0
# @USE_DXR3_TRUE@Obsoletes: gstreamer-dxr3
# @USE_DXR3_TRUE@
# @USE_DXR3_TRUE@%description -n gstreamer-plugins-dxr3
# @USE_DXR3_TRUE@Plug-in supporting DVD playback using cards
# @USE_DXR3_TRUE@with the dxr3 chipset like Hollywood Plus
# @USE_DXR3_TRUE@and Creative Labs DVD cards.
# @USE_DXR3_TRUE@
# @USE_DXR3_TRUE@%files -n gstreamer-plugins-dxr3
# @USE_DXR3_TRUE@%defattr(-, root, root)
# @USE_DXR3_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstdxr3.so
# @USE_DXR3_TRUE@
# @USE_DXR3_TRUE@%post -n gstreamer-plugins-dxr3
# @USE_DXR3_TRUE@%{register}
# @USE_DXR3_TRUE@
# @USE_DXR3_TRUE@%postun -n gstreamer-plugins-dxr3
# @USE_DXR3_TRUE@%{register}
### FAAC ###
# @USE_FAAC_TRUE@%package -n gstreamer-plugins-faac
# @USE_FAAC_TRUE@Summary:GStreamer plug-ins for AAC audio playback.
# @USE_FAAC_TRUE@Group: Applications/Multimedia
# @USE_FAAC_TRUE@Requires: gstreamer-plugins = %{version}
# @USE_FAAC_TRUE@Requires: faac >= 1.23
# @USE_FAAC_TRUE@BuildRequires: faac-devel >= 1.23
# @USE_FAAC_TRUE@Obsoletes: gstreamer-faac
# @USE_FAAC_TRUE@
# @USE_FAAC_TRUE@%description -n gstreamer-plugins-faac
# @USE_FAAC_TRUE@Plug-ins for playing AAC audio
# @USE_FAAC_TRUE@
# @USE_FAAC_TRUE@%files -n gstreamer-plugins-faac
# @USE_FAAC_TRUE@%defattr(-, root, root)
# @USE_FAAC_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstfaac.so
# @USE_FAAC_TRUE@%post -n gstreamer-faac
# @USE_FAAC_TRUE@%{register}
# @USE_FAAC_TRUE@
# @USE_FAAC_TRUE@%postun -n gstreamer-plugins-faac
# @USE_FAAC_TRUE@%{register}
#### JACK AUDIO CONNECTION KIT ###
# @USE_JACK_TRUE@%package -n gstreamer-plugins-jack
# @USE_JACK_TRUE@Summary: GStreamer plug-in for the Jack Sound Server.
# @USE_JACK_TRUE@Group: Applications/Multimedia
# @USE_JACK_TRUE@Requires: gstreamer-plugins = %{version}
# @USE_JACK_TRUE@Requires: jack-audio-connection-kit >= 0.28.0
# @USE_JACK_TRUE@
# @USE_JACK_TRUE@Provides: gstreamer-audiosrc
# @USE_JACK_TRUE@Provides: gstreamer-audiosink
# @USE_JACK_TRUE@Obsoletes: gstreamer-jack
# @USE_JACK_TRUE@
# @USE_JACK_TRUE@%description -n gstreamer-plugins-jack
# @USE_JACK_TRUE@Plug-in for the JACK professional sound server.
# @USE_JACK_TRUE@
# @USE_JACK_TRUE@%files -n gstreamer-plugins-jack
# @USE_JACK_TRUE@%defattr(-, root, root)
# @USE_JACK_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstjack.so
# @USE_JACK_TRUE@
# @USE_JACK_TRUE@%post -n gstreamer-plugins-jack
# @USE_JACK_TRUE@%{register}
# @USE_JACK_TRUE@
# @USE_JACK_TRUE@%postun -n gstreamer-plugins-jack
# @USE_JACK_TRUE@%{register}
#### NETWORK AUDIO SYSTEM ###
# @USE_NAS_TRUE@%package -n gstreamer-plugins-nas
# @USE_NAS_TRUE@Summary: GStreamer plug-in for the Network Audio System.
# @USE_NAS_TRUE@Group: Applications/Multimedia
# @USE_NAS_TRUE@Requires: gstreamer-plugins = %{version}
# @USE_NAS_TRUE@Requires: libnas2 >= 1.6
# @USE_NAS_TRUE@Obsolotes:gstreamer-nas
# @USE_NAS_TRUE@
# @USE_NAS_TRUE@%description -n gstreamer-plugins-nas
# @USE_NAS_TRUE@Plug-in for the Network Audio System sound server.
# @USE_NAS_TRUE@
# @USE_NAS_TRUE@%files -n gstreamer-plugins-nas
# @USE_NAS_TRUE@%defattr(-, root, root)
# @USE_NAS_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstnassink.so
# @USE_NAS_TRUE@
# @USE_NAS_TRUE@%post -n gstreamer-plugins-nas
# @USE_NAS_TRUE@%{register}
# @USE_NAS_TRUE@
# @USE_NAS_TRUE@%postun -n gstreamer-plugins-nas
# @USE_NAS_TRUE@%{register}
#### MMS Protocol support ####
# @USE_LIBMMS_TRUE@%package -n gstreamer-plugins-mms
# @USE_LIBMMS_TRUE@Summary: GStreamer plug-in for MMS protocol support
# @USE_LIBMMS_TRUE@Group: Applications/Multimedia
# @USE_LIBMMS_TRUE@Requires: gstreamer-plugins = %{version}
# @USE_LIBMMS_TRUE@Requires: libmms >= 0.1
# @USE_LIBMMS_TRUE@Obsoletes:gstreamer-mms
# @USE_LIBMMS_TRUE@
# @USE_LIBMMS_TRUE@%description -n gstreamer-plugins-mms
# @USE_LIBMMS_TRUE@Plug-in for the MMS protocol used by Microsoft
# @USE_LIBMMS_TRUE@
# @USE_LIBMMS_TRUE@%files -n gstreamer-plugins-mms
# @USE_LIBMMS_TRUE@%defattr(-, root, root)
# @USE_LIBMMS_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstmms.so
# @USE_LIBMMS_TRUE@
# @USE_LIBMMS_TRUE@%post -n gstreamer-plugins-mms
# @USE_LIBMMS_TRUE@%{register}
# @USE_LIBMMS_TRUE@
# @USE_LIBMMS_TRUE@%postun -n gstreamer-plugins-mms
# @USE_LIBMMS_TRUE@%{register}
### VIDEO 4 LINUX 2 ###
# @USE_GST_V4L2_TRUE@%package -n gstreamer-plugins-v4l2
# @USE_GST_V4L2_TRUE@Summary: GStreamer Video for Linux 2 plug-in.
# @USE_GST_V4L2_TRUE@Group: Applications/Multimedia
# @USE_GST_V4L2_TRUE@Requires: gstreamer-plugins = %{version}
# @USE_GST_V4L2_TRUE@BuildRequires: glibc-devel
# @USE_GST_V4L2_TRUE@Obsoletes: gstreamer-v4l2
# @USE_GST_V4L2_TRUE@
# @USE_GST_V4L2_TRUE@%description -n gstreamer-plugins-v4l2
# @USE_GST_V4L2_TRUE@Plug-in for accessing Video for Linux devices.
# @USE_GST_V4L2_TRUE@
# @USE_GST_V4L2_TRUE@%files -n gstreamer-plugins-v4l2
# @USE_GST_V4L2_TRUE@%defattr(-, root, root)
# @USE_GST_V4L2_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstvideo4linux2.so
# @USE_GST_V4L2_TRUE@
# @USE_GST_V4L2_TRUE@%post -n gstreamer-plugins-v4l2
# @USE_GST_V4L2_TRUE@%{register}
# @USE_GST_V4L2_TRUE@
# @USE_GST_V4L2_TRUE@%postun -n gstreamer-plugins-v4l2
# @USE_GST_V4L2_TRUE@%{register}
### XVID ###
# @USE_XVID_TRUE@%package -n gstreamer-plugins-xvid
# @USE_XVID_TRUE@Summary: GStreamer XVID plug-in.
# @USE_XVID_TRUE@Group: Applications/Multimedia
# @USE_XVID_TRUE@Requires: gstreamer-plugins = %{version}
# @USE_XVID_TRUE@BuildRequires: glibc-devel
# @USE_XVID_TRUE@Obsoletes: gstreamer-xvid
# @USE_XVID_TRUE@
# @USE_XVID_TRUE@%description -n gstreamer-plugins-xvid
# @USE_XVID_TRUE@Plug-in for decoding XVID files.
# @USE_XVID_TRUE@
# @USE_XVID_TRUE@%files -n gstreamer-plugins-xvid
# @USE_XVID_TRUE@%defattr(-, root, root)
# @USE_XVID_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstxvid.so
# @USE_XVID_TRUE@
# @USE_XVID_TRUE@%post -n gstreamer-plugins-xvid
# @USE_XVID_TRUE@%{register}
# @USE_XVID_TRUE@
# @USE_XVID_TRUE@%postun -n gstreamer-plugins-xvid
# @USE_XVID_TRUE@%{register}
# schema files
@USE_GCONF_TRUE@%{_sysconfdir}/gconf/schemas/gstreamer-%{majorminor}.schemas
%post
@USE_GCONF_TRUE@export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
@USE_GCONF_TRUE@gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gstreamer-%{majorminor}.schemas > /dev/null
%{register}
%postun
%{register}
%changelog
* Fri Sep 02 2005 Thomas Vander Stichele <thomas at apestaart dot org>
- clean up for splitup
* Mon Feb 14 2005 Christian Schaller <christian at fluendo dot com>
- Add vnc plugin
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment