Commit 82f2bf05 authored by Nicolas Dufresne's avatar Nicolas Dufresne
Browse files

v4l2: Don't require parser for VP8

Until GStreamer has one (see bug722760), we should not require a parser for VP8.

https://bugzilla.gnome.org/show_bug.cgi?id=722128
parent a1db7e8c
......@@ -2142,6 +2142,10 @@ static void
gst_v4l2_object_update_and_append (GstV4l2Object * v4l2object,
guint32 format, GstCaps * caps, GstStructure * s)
{
/* FIXME remove when VP8 parser is ready, bug #722760 */
if (format == V4L2_PIX_FMT_VP8)
goto done;
/* Encoded stream on output buffer need to be parsed */
if (v4l2object->type == V4L2_BUF_TYPE_VIDEO_OUTPUT ||
v4l2object->type == V4L2_BUF_TYPE_VIDEO_OUTPUT_MPLANE) {
......@@ -2156,6 +2160,7 @@ gst_v4l2_object_update_and_append (GstV4l2Object * v4l2object,
}
}
done:
gst_caps_append_structure (caps, s);
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment