Commit c0852624 authored by Brendan Long's avatar Brendan Long Committed by Sebastian Dröge

vp9dec: Require vpx >= 1.3.0 for building vp9dec and vp9enc

Previous versions did not have a stable bitstream for VP9.

https://bugzilla.gnome.org/show_bug.cgi?id=720986
parent 4baf8080
......@@ -960,14 +960,17 @@ AG_GST_CHECK_FEATURE(VPX, [VPX decoder], vpx, [
HAVE_VP8=yes
AC_DEFINE(HAVE_VP8_DECODER, 1, [Defined if the VP8 decoder is available])
])
AC_CHECK_LIB(vpx, vpx_codec_vp9_cx_algo, [
HAVE_VP9=yes
AC_DEFINE(HAVE_VP9_ENCODER, 1, [Defined if the VP9 encoder is available])
])
AC_CHECK_LIB(vpx, vpx_codec_vp9_dx_algo, [
HAVE_VP9=yes
AC_DEFINE(HAVE_VP9_DECODER, 1, [Defined if the VP9 decoder is available])
])
PKG_CHECK_MODULES(VPX_130, vpx >= 1.3.0, [
AC_CHECK_LIB(vpx, vpx_codec_vp9_cx_algo, [
HAVE_VP9=yes
AC_DEFINE(HAVE_VP9_ENCODER, 1, [Defined if the VP9 encoder is available])
])
AC_CHECK_LIB(vpx, vpx_codec_vp9_dx_algo, [
HAVE_VP9=yes
AC_DEFINE(HAVE_VP9_DECODER, 1, [Defined if the VP9 decoder is available])
])
], [true])
LIBS="$OLD_LIBS"
CFLAGS="$OLD_CFLAGS"
fi
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment