Commit d7ccf497 authored by Christian Schaller's avatar Christian Schaller

minor spec file fixes

Original commit message from CVS:
minor spec file fixes
parent 781bc330
......@@ -13,7 +13,7 @@
%define gst_minver 0.7.6
%define gstp_minver 0.7.6
Name: gstreamer-plugins
Name: gstreamer09-plugins
Version: @VERSION@
Release: @GST_PLUGINS_VERSION_RELEASE@
Summary: GStreamer Streaming-media framework plug-ins.
......@@ -31,9 +31,8 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-root
Requires: glib2 >= %_glib2
BuildRequires: glib2-devel >= %_glib2
Requires: gstreamer >= %{gst_minver}
BuildRequires: gstreamer-devel >= %{gst_minver}
BuildRequires: gstreamer-tools >= %{gst_minver}
Requires: gstreamer09 >= %{gst_minver}
BuildRequires: gstreamer09-devel >= %{gst_minver}
BuildRequires: gcc-c++
BuildRequires: XFree86-devel
......@@ -176,7 +175,7 @@ Group: Applications/Multimedia
# # @USE_SHOUT2_TRUE@BuildRequires: libshout-devel >= 2.0
# @USE_LADSPA_TRUE@BuildRequires: ladspa-devel
Requires: gstreamer-plugins >= %{gstp_minver}
Requires: gstreamer09-plugins >= %{gstp_minver}
Requires(pre): %{_bindir}/gst-register-%{majorminor}
Requires(post): %{_bindir}/gst-register-%{majorminor}
......@@ -213,7 +212,7 @@ Group: Applications/Multimedia
@USE_MAD_TRUE@BuildRequires: libid3tag-devel >= 0.15.0
@USE_MAD_TRUE@BuildRequires: libmad-devel >= 0.15.0
Requires: gstreamer-plugins >= %{gstp_minver}
Requires: gstreamer09-plugins >= %{gstp_minver}
Requires(pre): %{_bindir}/gst-register-%{majorminor}
Requires(post): %{_bindir}/gst-register-%{majorminor}
......@@ -249,8 +248,8 @@ Group: Applications/Multimedia
# @USE_DVDNAV_TRUE@BuildRequires: libdvdnav-devel >= 0.1.3
# @USE_DVDREAD_TRUE@BuildRequires: libdvdread-devel >= 0.9.0
Requires: gstreamer-plugins >= %{gstp_minver}
Requires: gstreamer-plugins-extra-video >= %{gstp_minver}
Requires: gstreamer09-plugins >= %{gstp_minver}
Requires: gstreamer09-plugins-extra-video >= %{gstp_minver}
Requires(pre): %{_bindir}/gst-register-%{majorminor}
Requires(post): %{_bindir}/gst-register-%{majorminor}
......@@ -282,7 +281,7 @@ Group: Applications/Multimedia
# @USE_AALIB_TRUE@BuildRequires: aalib-devel >= 1.3
Requires: gstreamer-plugins >= %{gstp_minver}
Requires: gstreamer09-plugins >= %{gstp_minver}
Requires(pre): %{_bindir}/gst-register-%{majorminor}
Requires(post): %{_bindir}/gst-register-%{majorminor}
......@@ -318,8 +317,8 @@ Group: Applications/Multimedia
# @USE_MPEG2DEC_TRUE@BuildRequires: mpeg2dec-devel >= 0.4.0
# @USE_SWFDEC_TRUE@BuildRequires: swfdec-devel
Requires: gstreamer-plugins >= %{gstp_minver}
Requires: gstreamer-plugins-extra-audio >= %{gstp_minver}
Requires: gstreamer09-plugins >= %{gstp_minver}
Requires: gstreamer09-plugins-extra-audio >= %{gstp_minver}
Requires(pre): %{_bindir}/gst-register-%{majorminor}
Requires(post): %{_bindir}/gst-register-%{majorminor}
......@@ -349,29 +348,6 @@ This package contains extra video plugins for GStreamer, including
# Here are all the packages depending on external libs #
### ALSA ###
# @USE_ALSA_TRUE@%package -n gstreamer-plugins-alsa
# @USE_ALSA_TRUE@Summary: GStreamer plug-ins for the ALSA sound system.
# @USE_ALSA_TRUE@Group: Applications/Multimedia
# @USE_ALSA_TRUE@Requires: gstreamer-plugins = %{version}
# @USE_ALSA_TRUE@Obsoletes:gstreamer-alsa
# @USE_ALSA_TRUE@
# @USE_ALSA_TRUE@Provides: gstreamer-audiosrc
# @USE_ALSA_TRUE@Provides: gstreamer-audiosink
# @USE_ALSA_TRUE@
# @USE_ALSA_TRUE@%description -n gstreamer-plugins-alsa
# @USE_ALSA_TRUE@Input and output plug-in for the ALSA soundcard driver system.
# @USE_ALSA_TRUE@This plug-in depends on Alsa 0.9.x or higher.
# @USE_ALSA_TRUE@
# @USE_ALSA_TRUE@%files -n gstreamer-plugins-alsa
# @USE_ALSA_TRUE@%defattr(-, root, root)
# @USE_ALSA_TRUE@%{_libdir}/gstreamer-%{majorminor}/libgstalsa.so
# @USE_ALSA_TRUE@
# @USE_ALSA_TRUE@%post -n gstreamer-plugins-alsa
# @USE_ALSA_TRUE@%{register}
# @USE_ALSA_TRUE@%postun -n gstreamer-plugins-alsa
# @USE_ALSA_TRUE@%{register}
## DXR3 ###
# @USE_DXR3_TRUE@%package -n gstreamer-plugins-dxr3
# @USE_DXR3_TRUE@Summary: GStreamer plug-in for playback using dxr3 card.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment