Commit 4e2095bd authored by Tim-Philipp Müller's avatar Tim-Philipp Müller

meson: fix with-package-name option

https://bugzilla.gnome.org/show_bug.cgi?id=784082
parent 0fd4a117
...@@ -135,13 +135,14 @@ cdata.set('GETTEXT_PACKAGE', '"gst-plugins-good-1.0"') ...@@ -135,13 +135,14 @@ cdata.set('GETTEXT_PACKAGE', '"gst-plugins-good-1.0"')
gst_package_name = get_option('with-package-name') gst_package_name = get_option('with-package-name')
if gst_package_name == '' if gst_package_name == ''
if gst_version_nano == 0 if gst_version_nano == 0
cdata.set_quoted('GST_PACKAGE_NAME', 'GStreamer Good Plug-ins source release') gst_package_name = 'GStreamer Good Plug-ins source release'
elif gst_version_nano == 1 elif gst_version_nano == 1
cdata.set_quoted('GST_PACKAGE_NAME', 'GStreamer Good Plug-ins git') gst_package_name = 'GStreamer Good Plug-ins git'
else else
cdata.set_quoted('GST_PACKAGE_NAME', 'GStreamer Good Plug-ins prerelease') gst_package_name = 'GStreamer Good Plug-ins prerelease'
endif endif
endif endif
cdata.set_quoted('GST_PACKAGE_NAME', gst_package_name)
cdata.set_quoted('GST_PACKAGE_ORIGIN', get_option('with-package-origin')) cdata.set_quoted('GST_PACKAGE_ORIGIN', get_option('with-package-origin'))
# Mandatory GST deps # Mandatory GST deps
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment