Commit d1acea57 authored by Tim-Philipp Müller's avatar Tim-Philipp Müller

REQUIREMENTS: update a little

People actually look at that it seems.
parent 69ec922c
GStreamer uses a *large* array of tools and libraries, most of which are
optional. We have attempted to make sure that any code that depends on
optional libraries doesn't get built unless you have those libraries. If
optional. We have attempted to make sure that any code that depends on
optional libraries doesn't get built unless you have those libraries. If
you find this not to be the case, please, let us know by filing a bug
report at http://bugzilla.gnome.org/.
On Debian/Ubuntu, the easiest way to install most build requirements is:
sudo apt-get build-dep gst-plugins-good1.0
Required tools:
===============
An extra set of tools is required if you wish to build GStreamer out of
CVS (using autogen.sh):
An extra set of tools is required if you wish to build GStreamer
from git (using autogen.sh):
autoconf 2.52 or better
automake 1.5
gettext 0.11.5
libtool v1.4 or better
pkgconfig 0.9.0 or better (http://www.freedesktop.org/software/pkgconfig/)
autoconf >= 2.68 https://www.gnu.org/software/autoconf/
automake >= 1.11 https://www.gnu.org/software/automake/
gettext >= 0.17 https://www.gnu.org/software/gettext/
libtool >= 2.2.6 https://www.gnu.org/software/libtool/
pkgconfig >= 0.9.0 https://www.freedesktop.org/software/pkgconfig/
Required libraries:
===================
Package: GStreamer
Version: 0.10.11.2
Recommended: 0.10.latest
URL: http://gstreamer.freedesktop.org/
DebianPackage: libgstreamer0.10-dev
Notes: The required version is updated frequently, so the version
listed in this file is often wrong. If you are compiling from CVS,
the required version is often the latest GStreamer CVS.
Package: GStreamer Base Plugins
Version: 0.10.11.2
Recommended: 0.10.latest
URL: http://gstreamer.freedesktop.org/
DebianPackage: libgstreamer-plugins-base0.10-dev
Notes: The required version is updated frequently, so the version
listed in this file is often wrong. If you are compiling from CVS,
the required version is often the latest GStreamer Base Plugins CVS.
Package: GStreamer
Version: 1.x (same 1.x version as this package)
Recommended: Latest 1.x
URL: http://gstreamer.freedesktop.org/
DebianPackage: libgstreamer1.0-dev
Notes: The required version is updated frequently, so the version
listed in this file is often out of date. If you are compiling
from git master, you will usually need GStreamer core and
gst-plugins-base from git master as well.
Package: GStreamer Base Plugins
Version: 1.x (same 1.x version as this package)
Recommended: Latest 1.x
URL: http://gstreamer.freedesktop.org/
DebianPackage: libgstreamer-plugins-base1.0-dev
Notes: The required version is updated frequently, so the version
listed in this file is often out of date. If you are compiling
from git master, you will usually need GStreamer core and
gst-plugins-base from git master as well.
Optional libraries:
===================
This file lists supporting libraries for which gst-plugins contains plugins,
as well as their minimum version. You can find the corresponding plugins in
ext/(library)
This file lists supporting libraries for which gst-plugins-good contains
plugins, as well as their minimum required version. You can find the
corresponding plugins in ext/(library)
Package: Orc
Version: >= 0.4.5
Recommended: 0.4.latest
URL: http://code.entropywave.com/orc
Version: >= 0.4.17
Recommended: Latest 0.4.x
URL: http://gstreamer.freedesktop.org/data/src/orc/
DebianPackage: liborc-0.4-dev
Notes: Used by many plugins for accelerating processing
Package: GTK+
Version: >= 2.0
Recommended: >= 2.2
URL: http://www.gtk.org/
DebianPackage: libgtk2.0-dev
Plugins: gdkpixbuf (gdkpixbufdec, gdkpixbufscale)
Notes: Also required by several examples. Plugin require >= 2.2.
Package: Check
DebianPackage: check
URL: http://check.sourceforge.net/
Package: Xlib
Plugins: ximagesrc, v4l2
DebianPackage: libx11-dev libxv-dev libxt-dev
Package: AALib
Plugins: aasink
URL: http://aa-project.sourceforge.net/aalib/
Package: LibXML
Version: >= 2.4.9
Plugins: annodex (cmmlenc, cmmldec)
URL: http://xmlsoft.org/
Package: Cairo
Version: >= 1.0
Plugins: cairo (cairotextoverlay, cairotimeoverlay)
URL: http://cairographics.org/
Package: CDIO
Version: >= 0.71
Plugins: cdio (cdiocddasrc)
URL: http://www.gnu.org/software/libcdio/
Package: FLAC
Version: == 1.1.2
Plugins: flac (flacenc, flacdec)
URL: http://flac.sourceforge.net/
Package: HAL
Version: >= 0.5.6
Plugins: halelements (halaudiosink, halaudiosrc)
URL: http://hal.freedesktop.org/
Package: IJG JPEG library
Plugins: jpeg (jpegenc, jpegdec, smokeenc, smokedec)
URL: http://www.ijg.org/
Package: LADSPA
Plugins: ladspa
URL: http://www.ladspa.org/
Package: Libcaca
Plugins: cacasink
URL: http://libcaca.zoy.org/
Package: Libdv
Version: >= 0.100
Plugins: dv (dvdec)
URL: http://libdv.sourceforge.net/
Package: Libpng
Version: >= 1.2
Plugins: png (pngenc, pngdec)
URL: http://www.libpng.org/pub/png/libpng.html
Package: libraw1394
Plugins: dv1394
URL: http://www.linux1394.org/
Package: libiec61883
Plugins: dv1394
URL: http://www.linux1394.org/
Package: libshout
Version: >= 2.0
URL: http://www.icecast.org/
Package: speex
Version: >= 1.0.4 or >= 1.1.5
Plugins: speex (speexenc, speexdec)
URL: http://www.speex.org/
Package: taglib
Version: >= 1.4
DebianPackage: libtag1-dev
URL: http://developer.kde.org/~wheeler/taglib.html
Package: zlib
Plugins: id3demux
URL: http://www.zlib.net/
Notes: Used by many plugins for accelerating SIMD processing using
run-time generated assembly. Not a hard requirement, but
highly recommended. Packagers, please hard-depend on liborc.
The git repository is http://cgit.freedesktop.org/gstreamer/orc/
(all versions on entropywave.com are outdated)
Package: gdk-pixbuf Library
Version: >= 2.8.0
Recommended: Latest 2.x
URL: http://www.gtk.org/
DebianPackage: libgdk-pixbuf2.0-dev
Plugins: gdkpixbuf (gdkpixbufdec, gdkpixbufoverlay)
Notes: This library does not depend on Gtk+ or Gdk or any window system
Package: GTK+
Version: >= 3.0
Recommended: Latest 3.x
URL: http://www.gtk.org/
DebianPackage: libgtk-3-dev
Plugins: None
Notes: Only needed by some of the examples, not by any plugins.
Package: Xlib
Plugins: ximagesrc
DebianPackage: libx11-dev libxv-dev libxt-dev
Package: AALib
Plugins: aasink
URL: http://aa-project.sourceforge.net/aalib/
Package: Cairo
Version: >= 1.10
DebianPackage: libcairo2-dev
Plugins: cairo (cairooverlay)
URL: http://cairographics.org/
Package: FLAC
Version: >= 1.1.4
DebianPackage: libflac-dev
Plugins: flac (flacenc, flacdec)
URL: http://flac.sourceforge.net/
Package: gudev
Version: >= 147
DebianPackage: libgudev-1.0-dev
Plugins: v4l2 (v4l2src)
URL: http://www.freedesktop.org/software/systemd/
Notes: This dependency is entirely optional, the video4linux plugin
will work just fine without it. gudev is only required for
the device probing and monitoring functionality to detect
video4linux devices appearing/disappearing at run-time.
Package: JPEG library
Plugins: jpeg (jpegenc, jpegdec, smokeenc, smokedec)
DebianPackage: libjpeg-dev
URL: http://www.libjpeg-turbo.org/
or http://www.ijg.org/ for the IJG version
Package: Libcaca
Plugins: cacasink
DebianPackage: libcaca-dev
URL: http://libcaca.zoy.org/
Package: Libdv
Version: >= 0.100
DebianPackage: libdv4-dev
Plugins: dv (dvdec)
URL: http://libdv.sourceforge.net/
Package: Libpng
Version: >= 1.2
DebianPackage: libpng12-dev
Plugins: png (pngenc, pngdec)
URL: http://www.libpng.org/pub/png/libpng.html
Package: libraw1394
Plugins: dv1394
URL: http://www.linux1394.org/
Package: libshout
Version: >= 2.0
DebianPackage: libshout3-dev
plugins: shout2 (shout2send)
URL: http://www.icecast.org/
Package: speex
Version: >= 1.1.6
Plugins: speex (speexenc, speexdec)
URL: http://www.speex.org/
Package: taglib
Version: >= 1.5
DebianPackage: libtag1-dev
Plugins: taglib (id3v2mux)
URL: http://taglib.github.io/
Package: zlib
DebianPackage: zlib1g-dev
Plugins: isomp4 (qtdemux), matroska (matroskademux)
URL: http://www.zlib.net/
Optional (debian) packages:
===========================
gtk-doc-tools 1.6 -- needed to build documentation
gtk-doc-tools >= 1.12 -- needed to build documentation
python-xml -- needed to build plugin documentation
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment