Commit 3dd87082 authored by Rohan Garg's avatar Rohan Garg Committed by Olivier Crête

Set the minimum GLib version to 2.30 to disable deprecated warnings on newer...

Set the minimum GLib version to 2.30 to disable deprecated warnings on newer GLib versions and make sure the maximum allowed GLib version is 2.32

Also actually require 2.30
parent e176b414
......@@ -90,7 +90,10 @@ AC_CHECK_HEADERS([ifaddrs.h], \
[AC_DEFINE(HAVE_GETIFADDRS, [1], \
[Whether getifaddrs() is available on the system])])
LIBNICE_CFLAGS="-Wall"
# Also put matching version in LIBNICE_CFLAGS
GLIB_REQ=2.30
LIBNICE_CFLAGS="-Wall -DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_30 -DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_32"
dnl if asked for, add -Werror if supported
if test "x$LIBNICE_RELEASE" != "xyes"; then
LIBNICE_CFLAGS="$LIBNICE_CFLAGS -Werror"
......@@ -105,10 +108,10 @@ AC_CHECK_FUNCS([poll])
AC_SUBST(LIBRT)
PKG_CHECK_MODULES(GLIB, [dnl
glib-2.0 >= 2.13 dnl
gobject-2.0 >= 2.13 dnl
gthread-2.0 >= 2.13 dnl
gio-2.0 >= 2.13 dnl
glib-2.0 >= $GLIB_REQ dnl
gobject-2.0 >= $GLIB_REQ dnl
gthread-2.0 >= $GLIB_REQ dnl
gio-2.0 >= $GLIB_REQ dnl
])
AC_ARG_WITH(gstreamer,
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment