Commit d91c6efd authored by Olivier Crête's avatar Olivier Crête

meson: Require very latest 0.49.1 as older versions break in our CI

Also remove workarounds for the older versions.
parent 856dbfcc
......@@ -2,10 +2,6 @@ stages:
- build
- test
# Workaround for https://github.com/mesonbuild/meson/issues/4718
variables:
LANG: en_US.utf8
build autotools:
stage: build
image: registry.freedesktop.org/ocrete/libnice/centos7/autotools-build
......@@ -85,7 +81,6 @@ test meson:
- schedules
script:
- ifconfig
- unset GITLAB_USER_NAME
- source scl_source enable rh-python36 && true
- meson test -C build/ --print-errorlogs
artifacts:
......
project('libnice', 'c',
version: '0.1.15.1',
meson_version : '>= 0.49.0',
meson_version : '>= 0.49.1',
default_options : ['warning_level=1', 'buildtype=debugoptimized'])
nice_version = meson.project_version()
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment