• Philip Withnall's avatar
    build: Add GObject introspection support · 0388646b
    Philip Withnall authored
    This bumps our autoconf requirement to 2.62 (from 2.59c) and disables
    automake portability warnings.
    
    It does not introduce a hard dependency on gobject-introspection; but if
    available, it requires version 1.30.0. Support can be enabled with
    --enable-introspection, and is required to make distcheck.
    
    The generated introspection file has not been checked thoroughly, and
    may expose internal symbols. A lot of new annotations are needed to make
    many of the symbols usable.
    0388646b
Name
Last commit
Last update
agent Loading commit data...
docs Loading commit data...
examples Loading commit data...
gst Loading commit data...
m4 Loading commit data...
nice Loading commit data...
random Loading commit data...
scripts Loading commit data...
socket Loading commit data...
stun Loading commit data...
tests Loading commit data...
win32/vs9 Loading commit data...
.gitignore Loading commit data...
AUTHORS Loading commit data...
COPYING Loading commit data...
COPYING.LGPL Loading commit data...
COPYING.MPL Loading commit data...
ChangeLog Loading commit data...
Makefile.am Loading commit data...
NEWS Loading commit data...
README Loading commit data...
README.win32 Loading commit data...
TODO Loading commit data...
autogen.sh Loading commit data...
common.mk Loading commit data...
configure.ac Loading commit data...