Commit 44bbbcf9 authored by Martin Pitt's avatar Martin Pitt
Browse files

Build python3-systemd for Python 3 bindings.

Drop python-systemd; it does not have any reverse dependencies, and we want to
encourage moving to Python 3. This also avoids having to do another source
build.

LP: #1258089
parent 1608ddfd
......@@ -21,6 +21,9 @@ systemd (208-7) UNRELEASED; urgency=medium
Drop "isolation-machine" requirement.
* Use glibc's xattr support instead of requiring libattr. Fixes FTBFS with
latest glibc and libattr. Cherrypicked from trunk. (Closes: #756097)
* Build python3-systemd for Python 3 bindings. Drop python-systemd; it does
not have any reverse dependencies, and we want to encourage moving to
Python 3. (LP: #1258089)
-- Michael Biebl <biebl@debian.org> Thu, 17 Jul 2014 00:48:14 +0200
......
......@@ -37,7 +37,7 @@ Build-Depends: debhelper (>= 9),
libblkid-dev (>= 2.20),
libgirepository1.0-dev (>= 1.31.1),
gobject-introspection (>= 1.31.1),
python-dev,
python3-all-dev,
libglib2.0-doc
Package: systemd
......@@ -343,15 +343,15 @@ Description: libgudev-1.0 development files
This package contains the files needed for developing applications that
use libgudev-1.0.
Package: python-systemd
Package: python3-systemd
Section: python
Priority: optional
Architecture: linux-any
Depends: ${shlibs:Depends},
${misc:Depends},
${python:Depends}
Description: python bindings for systemd
This package contains Python bindings for the systemd libraries.
${python3:Depends}
Description: Python 3 bindings for systemd
This package contains Python 3 bindings for the systemd libraries.
Package: systemd-dbg
Architecture: linux-any
......
usr/lib/python*/dist-packages/systemd
usr/lib/python*/*-packages/systemd
......@@ -31,7 +31,9 @@ endif
CONFFLAGS_deb = \
--enable-selinux \
--enable-introspection \
--enable-gtk-doc
--enable-gtk-doc \
PYTHON=python3 \
$(NULL)
CONFFLAGS_udeb = \
--disable-selinux \
......@@ -219,7 +221,7 @@ override_dh_strip:
%:
ifeq (,$(findstring stage1,$(DEB_BUILD_PROFILES)))
dh $@ --with autoreconf,gir,python2
dh $@ --with autoreconf,gir,python3
else
dh $@ --with autoreconf,python2 $(BOOTSTRAP_DH_FLAGS)
dh $@ --with autoreconf,python3 $(BOOTSTRAP_DH_FLAGS)
endif
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment