Commit 965ef72d authored by Martin Pitt's avatar Martin Pitt
Browse files

Drop seddery for getty-static.service

Check for existance of /lib/systemd/system/dbus.service instead of dbus-daemon,
which works on Debian and Ubuntu, and is slightly more correct too.
parent c4b5782f
[Unit]
Description=getty on tty2-tty6 if dbus and logind are not available
ConditionPathExists=/dev/tty2
ConditionFileIsExecutable=!@DBUS_DAEMONDIR@/dbus-daemon
ConditionPathExists=!/lib/systemd/system/dbus.service
[Service]
Type=oneshot
......
......@@ -183,7 +183,7 @@ override_dh_install:
debian/systemd/lib/lsb/init-functions.d/40-systemd
install --mode=644 debian/tmpfiles.d/debian.conf \
debian/systemd/usr/lib/tmpfiles.d/
install --mode=644 debian/debian-fixup.service debian/ifup@.service \
install --mode=644 debian/debian-fixup.service debian/ifup@.service debian/extra/getty-static.service \
debian/systemd/lib/systemd/system/
install -D --mode=644 debian/extra/network-pre.conf \
debian/systemd/lib/systemd/system/networking.service.d/network-pre.conf
......@@ -236,9 +236,6 @@ endif
rm debian/udev/lib/udev/rules.d/71-seat.rules
rm debian/udev/lib/udev/rules.d/99-systemd.rules
# Debian specific units
sed "s!@DBUS_DAEMONDIR@!$$(pkg-config --variable=daemondir dbus-1)!" < debian/extra/getty-static.service.in > debian/systemd/lib/systemd/system/getty-static.service
# use symlinked doc directories as the old udev package did
override_dh_installdocs:
dh_installdocs -pudev -plibudev-dev --link-doc=libudev1
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment