Commit d26405c8 authored by Martin Pitt's avatar Martin Pitt
Browse files

Actually install udev's README.Debian when building for Debian

Closes: #776546
parent a76b4544
...@@ -3,6 +3,8 @@ systemd (215-12) UNRELEASED; urgency=medium ...@@ -3,6 +3,8 @@ systemd (215-12) UNRELEASED; urgency=medium
* debian/udev.README.Debian: Trim the parts which are obsolete, wrong, or * debian/udev.README.Debian: Trim the parts which are obsolete, wrong, or
described in manpages. Only keep the Debian specific bits. described in manpages. Only keep the Debian specific bits.
(Part of #776546) (Part of #776546)
* Actually install udev's README.Debian when building for Debian.
(Closes: #776546)
-- Martin Pitt <martin.pitt@ubuntu.com> Fri, 30 Jan 2015 15:56:22 +0100 -- Martin Pitt <martin.pitt@ubuntu.com> Fri, 30 Jan 2015 15:56:22 +0100
......
...@@ -239,6 +239,8 @@ endif ...@@ -239,6 +239,8 @@ endif
# use symlinked doc directories as the old udev package did # use symlinked doc directories as the old udev package did
override_dh_installdocs: override_dh_installdocs:
dh_installdocs -pudev -plibudev-dev --link-doc=libudev1 dh_installdocs -pudev -plibudev-dev --link-doc=libudev1
# we have to manually install udev's README for the above
install -D --mode 644 debian/udev.README.Debian debian/libudev1/usr/share/doc/libudev1/README.Debian
dh_installdocs -pgir1.2-gudev-1.0 -plibgudev-1.0-dev --link-doc=libgudev-1.0-0 dh_installdocs -pgir1.2-gudev-1.0 -plibgudev-1.0-dev --link-doc=libgudev-1.0-0
dh_installdocs --remaining-packages dh_installdocs --remaining-packages
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment