Commit e75c0580 authored by Kay Sievers's avatar Kay Sievers
Browse files

gnome-ask-password-agent.vala: check for VALA_0_12

<juergbi> VALA_0_X is defined up to and including the current version
<juergbi> so VALA_0_10 is defined in 0.10 and 0.11 and 0.12
<juergbi> VALA_0_12 is defined in 0.11 and 0.12 (and later versions)
<juergbi> reverse the branches and use VALA_0_12 as conditional
<kay> juergbi: changing api but keep the defines?
<kay> how do we support vala 0.14 then?
<kay> you keep that model with the old defines?
<juergbi> VALA_0_10 corresponds to valaversion >= 0.10
parent 202df05e
......@@ -239,10 +239,10 @@ public class MyStatusIcon : StatusIcon {
null);
OutputStream stream = new UnixOutputStream(to_process, true);
#if VALA_0_10
stream.write(password, password.length, null);
#else
#if VALA_0_12
stream.write(password.data, null);
#else
stream.write(password, password.length, null);
#endif
} catch (Error e) {
show_error(e.message);
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment