Commit 11623be9 authored by Jonathan Gray's avatar Jonathan Gray Committed by Emil Velikov

automake: don't enable -Wl,--no-undefined on OpenBSD

OpenBSD does not have DT_NEEDED entries for libc by design,
over concerns how the symbols would be referenced after
changing the major version of the library.

So avoid -no-undefined checks on OpenBSD as they will fail.

v2: don't include the -no-undefined libtool option in the variable
    and change -Wl,--no-undefined references in Automake.inc as well.

Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=76856Signed-off-by: default avatarJonathan Gray <jsg@jsg.id.au>
Reviewed-by: default avatarEmil Velikov <emil.l.velikov@gmail.com>
Reviewed-by: default avatarMatt Turner <mattst88@gmail.com>
parent e4bd00c1
......@@ -78,7 +78,7 @@ libEGL_la_LDFLAGS = \
-version-number 1:0 \
-Wl,-Bsymbolic \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
if HAVE_EGL_PLATFORM_X11
AM_CFLAGS += -DHAVE_X11_PLATFORM
......
......@@ -12,7 +12,7 @@ libwayland_egl_la_LDFLAGS = \
-no-undefined \
-version-info 1 \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
TESTS = wayland-egl-symbols-check
......
......@@ -67,7 +67,7 @@ GALLIUM_VDPAU_LINKER_FLAGS = \
-version-number $(VDPAU_MAJOR):$(VDPAU_MINOR) \
-export-symbols-regex $(VDPAU_EXPORTS) \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
GALLIUM_XVMC_LINKER_FLAGS = \
-shared \
......@@ -76,7 +76,7 @@ GALLIUM_XVMC_LINKER_FLAGS = \
-version-number $(XVMC_MAJOR):$(XVMC_MINOR) \
-export-symbols-regex '^XvMC' \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
GALLIUM_OMX_LINKER_FLAGS = \
-shared \
......@@ -84,7 +84,7 @@ GALLIUM_OMX_LINKER_FLAGS = \
-no-undefined \
-export-symbols-regex $(EXPORTS) \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
GALLIUM_COMMON_LIB_DEPS = \
-lm \
......
......@@ -49,7 +49,7 @@ AM_LDFLAGS = \
-no-undefined \
-avoid-version \
$(GC_SECTIONS) \
-Wl,--no-undefined \
$(LD_NO_UNDEFINED) \
-Wl,--version-script=$(top_srcdir)/src/gallium/targets/egl-static/egl.link
egldir = $(EGL_DRIVER_INSTALL_DIR)
......
......@@ -68,7 +68,7 @@ gbm_gallium_drm_la_LDFLAGS = \
-no-undefined \
-avoid-version \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
if HAVE_MESA_LLVM
gbm_gallium_drm_la_LIBADD += $(LLVM_LIBS)
......
......@@ -48,7 +48,7 @@ libGL_la_LDFLAGS = \
-no-undefined \
-version-number $(GL_MAJOR):$(GL_MINOR):$(GL_TINY) \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
libGL_la_LIBADD = \
$(top_builddir)/src/gallium/state_trackers/glx/xlib/libxlib.la \
......
......@@ -7,7 +7,7 @@ lib@OPENCL_LIBNAME@_la_LDFLAGS = \
-no-undefined \
-version-number 1:0 \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
lib@OPENCL_LIBNAME@_la_LIBADD = \
......
......@@ -44,7 +44,7 @@ lib@OSMESA_LIB@_la_LDFLAGS = \
-no-undefined \
-version-number @OSMESA_VERSION@ \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
if HAVE_SHARED_GLAPI
......
......@@ -47,7 +47,7 @@ AM_LDFLAGS = \
-no-undefined \
-avoid-version \
$(GC_SECTIONS) \
-Wl,--no-undefined \
$(LD_NO_UNDEFINED) \
-Wl,--version-script=$(top_srcdir)/src/gallium/targets/pipe-loader/pipe.link
if HAVE_MESA_LLVM
......
......@@ -64,7 +64,7 @@ libxatracker_la_LDFLAGS = \
-no-undefined \
-version-number $(XA_MAJOR):$(XA_MINOR):$(XA_TINY) \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
if HAVE_MESA_LLVM
libxatracker_la_LIBADD += $(LLVM_LIBS)
......
......@@ -23,7 +23,7 @@ libgbm_la_LDFLAGS = \
-no-undefined \
-version-info 1:0 \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
libgbm_la_LIBADD = \
$(top_builddir)/src/loader/libloader.la \
......
......@@ -113,7 +113,7 @@ GL_LDFLAGS = \
-version-number 1:2 \
-Wl,-Bsymbolic \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
lib@GL_LIB@_la_SOURCES =
lib@GL_LIB@_la_LIBADD = $(GL_LIBS)
......
......@@ -48,7 +48,7 @@ libGLESv1_CM_la_LDFLAGS = \
-no-undefined \
-version-number 1:1 \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
if HAVE_SHARED_GLAPI
libGLESv1_CM_la_LIBADD += ../shared-glapi/libglapi.la
......
......@@ -53,7 +53,7 @@ libGLESv2_la_LDFLAGS = \
-no-undefined \
-version-number 2 \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
if HAVE_SHARED_GLAPI
libGLESv2_la_LIBADD += ../shared-glapi/libglapi.la
......
......@@ -12,7 +12,7 @@ libglapi_la_LIBADD = $(PTHREAD_LIBS) $(SELINUX_LIBS)
libglapi_la_LDFLAGS = \
-no-undefined \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
include $(GLAPI)/gen/glapi_gen.mk
glapi_mapi_tmp.h : $(GLAPI)/gen/gl_and_es_API.xml $(glapi_gen_mapi_deps)
......
......@@ -48,7 +48,7 @@ libOpenVG_la_LDFLAGS = \
-no-undefined \
-version-number 1 \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
vgapi_tmp.h: $(srcdir)/vgapi.csv $(top_srcdir)/src/mapi/mapi_abi.py
$(AM_V_GEN) $(PYTHON2) $(PYTHON_FLAGS) $(top_srcdir)/src/mapi/mapi_abi.py \
......
......@@ -40,7 +40,7 @@ lib@OSMESA_LIB@_la_LDFLAGS = \
-no-undefined \
-version-number @OSMESA_VERSION@ \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
if HAVE_SHARED_GLAPI
......
......@@ -65,6 +65,6 @@ lib@GL_LIB@_la_LDFLAGS = \
-no-undefined \
-version-number $(GL_MAJOR):$(GL_MINOR):$(GL_PATCH) \
$(GC_SECTIONS) \
-Wl,--no-undefined
$(LD_NO_UNDEFINED)
include $(top_srcdir)/install-lib-links.mk
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment