Commit 1a0aa468 authored by Tobias Droste's avatar Tobias Droste Committed by Emil Velikov

configure.ac: Don't check LLVM version in gallium_require_llvm

This is actually not needed because the version is checked later.

Line 2609:
if test "x$enable_gallium_llvm" == "xyes"; then
    llvm_require_version $LLVM_REQUIRED_GALLIUM "gallium"
    llvm_add_default_components "gallium"

    HAVE_GALLIUM_LLVM=xyes
    DEFINES="${DEFINES} -DHAVE_GALLIUM_LLVM"
fi
Signed-off-by: default avatarTobias Droste <tdroste@gmx.de>
Reviewed-by: default avatarEmil Velikov <emil.velikov@collabora.com>
parent 4d0efb96
......@@ -2387,9 +2387,7 @@ dnl
dnl Gallium helper functions
dnl
gallium_require_llvm() {
if test "x$enable_gallium_llvm" = "xyes"; then
llvm_require_version $LLVM_REQUIRED_GALLIUM "gallium"
else
if test "x$enable_gallium_llvm" != "xyes"; then
AC_MSG_ERROR([--enable-gallium-llvm is required when building $1])
fi
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment