Commit 518d8065 authored by Marek Olšák's avatar Marek Olšák

mesa: expose ARB_gpu_shader5 in the compatibility profile

Gallium drivers don't expose this yet due to:
    "st/mesa: use PIPE_CAP_GLSL_FEATURE_LEVEL_COMPATIBILITY"
Reviewed-by: default avatarTimothy Arceri <tarceri@itsqueeze.com>
parent dd93bc4f
......@@ -224,8 +224,10 @@ intelInitExtensions(struct gl_context *ctx)
ctx->Extensions.ARB_conservative_depth = true;
ctx->Extensions.ARB_derivative_control = true;
ctx->Extensions.ARB_framebuffer_no_attachments = true;
ctx->Extensions.ARB_gpu_shader5 = true;
ctx->Extensions.ARB_gpu_shader_fp64 = devinfo->has_64bit_types;
if (ctx->API != API_OPENGL_COMPAT) {
ctx->Extensions.ARB_gpu_shader5 = true;
ctx->Extensions.ARB_gpu_shader_fp64 = devinfo->has_64bit_types;
}
ctx->Extensions.ARB_shader_atomic_counters = true;
ctx->Extensions.ARB_shader_atomic_counter_ops = true;
ctx->Extensions.ARB_shader_clock = true;
......
......@@ -74,7 +74,7 @@ EXT(ARB_framebuffer_sRGB , EXT_framebuffer_sRGB
EXT(ARB_get_program_binary , dummy_true , GLL, GLC, x , x , 2010)
EXT(ARB_get_texture_sub_image , dummy_true , GLL, GLC, x , x , 2014)
EXT(ARB_gl_spirv , ARB_gl_spirv , x, GLC, x , x , 2016)
EXT(ARB_gpu_shader5 , ARB_gpu_shader5 , x , GLC, x , x , 2010)
EXT(ARB_gpu_shader5 , ARB_gpu_shader5 , GLL, GLC, x , x , 2010)
EXT(ARB_gpu_shader_fp64 , ARB_gpu_shader_fp64 , x , GLC, x , x , 2010)
EXT(ARB_gpu_shader_int64 , ARB_gpu_shader_int64 , x , GLC, x , x , 2015)
EXT(ARB_half_float_pixel , dummy_true , GLL, GLC, x , x , 2003)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment