Commit 7983adc6 authored by Eric Engestrom's avatar Eric Engestrom
Browse files

meson: be explicit about the version required



This way, we know what we're allowed to use (no nested include lists
for instance) and users get immediate feedback when trying to use
unsupported versions, rather than a cryptic crash or things being
silently not built correctly.

Cc: Dylan Baker <dylan@pnwbakers.com>
Signed-off-by: default avatarEric Engestrom <eric.engestrom@imgtec.com>
Reviewed-by: default avatarDylan Baker <dylan@pnwbakers.com>
parent 9e5a5a11
......@@ -18,8 +18,14 @@
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
# SOFTWARE.
project('mesa', ['c', 'cpp'], version : '17.3.0-devel', license : 'MIT',
default_options : ['c_std=c99', 'cpp_std=c++11'])
project(
'mesa',
['c', 'cpp'],
version : '17.3.0-devel',
license : 'MIT',
meson_version : '>= 0.42',
default_options : ['c_std=c99', 'cpp_std=c++11']
)
# Arguments for the preprocessor, put these in a separate array from the C and
# C++ (cpp in meson terminology) arguments since they need to be added to the
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment