meson.build 51.6 KB
Newer Older
1
# Copyright © 2017-2019 Intel Corporation
2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20

# Permission is hereby granted, free of charge, to any person obtaining a copy
# of this software and associated documentation files (the "Software"), to deal
# in the Software without restriction, including without limitation the rights
# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
# copies of the Software, and to permit persons to whom the Software is
# furnished to do so, subject to the following conditions:

# The above copyright notice and this permission notice shall be included in
# all copies or substantial portions of the Software.

# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
# SOFTWARE.

21 22 23
project(
  'mesa',
  ['c', 'cpp'],
24 25 26
  version : run_command(
    [find_program('python', 'python2', 'python3'), 'bin/meson_get_version.py']
  ).stdout(),
27
  license : 'MIT',
28 29
  meson_version : '>= 0.45',
  default_options : ['buildtype=debugoptimized', 'b_ndebug=if-release', 'c_std=c99', 'cpp_std=c++11']
30
)
31

32 33 34
cc = meson.get_compiler('c')
cpp = meson.get_compiler('cpp')

35 36
null_dep = dependency('', required : false)

37 38 39 40 41 42 43
# Arguments for the preprocessor, put these in a separate array from the C and
# C++ (cpp in meson terminology) arguments since they need to be added to the
# default arguments for both C and C++.
pre_args = [
  '-D__STDC_CONSTANT_MACROS',
  '-D__STDC_FORMAT_MACROS',
  '-D__STDC_LIMIT_MACROS',
44
  '-DPACKAGE_VERSION="@0@"'.format(meson.project_version()),
45 46 47
  '-DPACKAGE_BUGREPORT="https://bugs.freedesktop.org/enter_bug.cgi?product=Mesa"',
]

48
with_vulkan_icd_dir = get_option('vulkan-icd-dir')
49 50
with_tests = get_option('build-tests')
with_valgrind = get_option('valgrind')
51
with_libunwind = get_option('libunwind')
52
with_asm = get_option('asm')
53
with_glx_read_only_text = get_option('glx-read-only-text')
54
with_glx_direct = get_option('glx-direct')
55
with_osmesa = get_option('osmesa')
56 57
with_swr_arches = get_option('swr-arches')
with_tools = get_option('tools')
58
if with_tools.contains('all')
59
  with_tools = ['etnaviv', 'freedreno', 'glsl', 'intel', 'nir', 'nouveau', 'xvmc']
60
endif
61

62 63
dri_drivers_path = get_option('dri-drivers-path')
if dri_drivers_path == ''
64
  dri_drivers_path = join_paths(get_option('prefix'), get_option('libdir'), 'dri')
65
endif
66 67
dri_search_path = get_option('dri-search-path')
if dri_search_path == ''
68
  dri_search_path = dri_drivers_path
69
endif
70

71 72
with_gles1 = get_option('gles1')
with_gles2 = get_option('gles2')
73 74 75 76 77 78 79 80
if host_machine.system() == 'windows'
  if with_gles1 == 'auto'
    with_gles1 = 'false'
  endif
  if with_gles2 == 'auto'
    with_gles2 = 'false'
  endif
endif
81
with_opengl = get_option('opengl')
82
with_shared_glapi = get_option('shared-glapi')
83 84 85

# shared-glapi is required if at least two OpenGL APIs are being built
if not with_shared_glapi
86 87 88
  if ((with_gles1 == 'true' and with_gles2 == 'true') or 
      (with_gles1 == 'true' and with_opengl) or
      (with_gles2 == 'true' and with_opengl))
89 90
    error('shared-glapi required for building two or more of OpenGL, OpenGL ES 1.x, OpenGL ES 2.x')
  endif
91 92
  with_gles1 = 'false'
  with_gles2 = 'false'
93 94 95
endif

# We require OpenGL for OpenGL ES
96 97 98 99 100 101
if not with_opengl
  if (with_gles1 == 'true' or with_gles2 == 'true') and not with_opengl
    error('building OpenGL ES without OpenGL is not supported.')
  endif
  with_gles1 = 'false'
  with_gles2 = 'false'
102 103
endif

104 105 106 107 108 109
with_gles1 = with_gles1 != 'false'
with_gles2 = with_gles2 != 'false'
with_any_opengl = with_opengl or with_gles1 or with_gles2
# Only build shared_glapi if at least one OpenGL API is enabled
with_shared_glapi = get_option('shared-glapi') and with_any_opengl

110 111
system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'dragonfly', 'linux'].contains(host_machine.system())

112 113
dri_drivers = get_option('dri-drivers')
if dri_drivers.contains('auto')
114
  if system_has_kms_drm
115
    # TODO: PPC, Sparc
116
    if ['x86', 'x86_64'].contains(host_machine.cpu_family())
117
      dri_drivers = ['i915', 'i965', 'r100', 'r200', 'nouveau']
118
    elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
119
      dri_drivers = []
120
    else
121 122
      error('Unknown architecture @0@. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.'.format(
            host_machine.cpu_family()))
123
    endif
124
  elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
125
    # only swrast would make sense here, but gallium swrast is a much better default
126
    dri_drivers = []
127
  else
128 129
    error('Unknown OS @0@. Please pass -Ddri-drivers to set driver options. Patches gladly accepted to fix this.'.format(
          host_machine.system()))
130 131
  endif
endif
132

133 134 135 136 137 138
with_dri_i915 = dri_drivers.contains('i915')
with_dri_i965 = dri_drivers.contains('i965')
with_dri_r100 = dri_drivers.contains('r100')
with_dri_r200 = dri_drivers.contains('r200')
with_dri_nouveau = dri_drivers.contains('nouveau')
with_dri_swrast = dri_drivers.contains('swrast')
139

140
with_dri = dri_drivers.length() != 0 and dri_drivers != ['']
141

142 143
gallium_drivers = get_option('gallium-drivers')
if gallium_drivers.contains('auto')
144
  if system_has_kms_drm
145 146
    # TODO: PPC, Sparc
    if ['x86', 'x86_64'].contains(host_machine.cpu_family())
147
      gallium_drivers = [
148 149
        'r300', 'r600', 'radeonsi', 'nouveau', 'virgl', 'svga', 'swrast'
      ]
150
    elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
151
      gallium_drivers = [
152
        'kmsro', 'v3d', 'vc4', 'freedreno', 'etnaviv', 'nouveau',
Qiang Yu's avatar
Qiang Yu committed
153
        'tegra', 'virgl', 'lima', 'swrast'
154
      ]
155
    else
156 157
      error('Unknown architecture @0@. Please pass -Dgallium-drivers to set driver options. Patches gladly accepted to fix this.'.format(
            host_machine.cpu_family()))
158
    endif
159
  elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
160
    gallium_drivers = ['swrast']
161
  else
162 163
    error('Unknown OS @0@. Please pass -Dgallium-drivers to set driver options. Patches gladly accepted to fix this.'.format(
          host_machine.system()))
164 165
  endif
endif
166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183
with_gallium_kmsro = gallium_drivers.contains('kmsro')
with_gallium_radeonsi = gallium_drivers.contains('radeonsi')
with_gallium_r300 = gallium_drivers.contains('r300')
with_gallium_r600 = gallium_drivers.contains('r600')
with_gallium_nouveau = gallium_drivers.contains('nouveau')
with_gallium_freedreno = gallium_drivers.contains('freedreno')
with_gallium_softpipe = gallium_drivers.contains('swrast')
with_gallium_vc4 = gallium_drivers.contains('vc4')
with_gallium_v3d = gallium_drivers.contains('v3d')
with_gallium_panfrost = gallium_drivers.contains('panfrost')
with_gallium_etnaviv = gallium_drivers.contains('etnaviv')
with_gallium_tegra = gallium_drivers.contains('tegra')
with_gallium_iris = gallium_drivers.contains('iris')
with_gallium_i915 = gallium_drivers.contains('i915')
with_gallium_svga = gallium_drivers.contains('svga')
with_gallium_virgl = gallium_drivers.contains('virgl')
with_gallium_swr = gallium_drivers.contains('swr')
with_gallium_lima = gallium_drivers.contains('lima')
184

185
if cc.get_id() == 'intel'
Vinson Lee's avatar
Vinson Lee committed
186
  if meson.version().version_compare('< 0.49.0')
187
    error('Meson does not have sufficient support of ICC before 0.49.0 to compile mesa')
Vinson Lee's avatar
Vinson Lee committed
188
  elif with_gallium_swr and meson.version().version_compare('== 0.49.0')
189 190 191 192
    warning('Meson as of 0.49.0 is sufficient for compiling mesa with ICC, but there are some caveats with SWR. 0.49.1 should resolve all of these')
  endif
endif

193
with_gallium = gallium_drivers.length() != 0 and gallium_drivers != ['']
194 195 196 197 198 199

if with_gallium and system_has_kms_drm
  _glx = get_option('glx')
  _egl = get_option('egl')
  if _glx == 'dri' or _egl == 'true' or (_glx == 'disabled' and _egl != 'false')
    with_dri = true
200
  endif
Ville Syrjälä's avatar
Ville Syrjälä committed
201 202
endif

203
_vulkan_drivers = get_option('vulkan-drivers')
204
if _vulkan_drivers.contains('auto')
205
  if system_has_kms_drm
206
    if host_machine.cpu_family().startswith('x86')
207
      _vulkan_drivers = ['amd', 'intel']
208 209
    elif ['arm', 'aarch64'].contains(host_machine.cpu_family())
      _vulkan_drivers = []
210
    else
211 212
      error('Unknown architecture @0@. Please pass -Dvulkan-drivers to set driver options. Patches gladly accepted to fix this.'.format(
            host_machine.cpu_family()))
213
    endif
214
  elif ['darwin', 'windows', 'cygwin', 'haiku'].contains(host_machine.system())
215
    # No vulkan driver supports windows or macOS currently
216
    _vulkan_drivers = []
217
  else
218 219
    error('Unknown OS @0@. Please pass -Dvulkan-drivers to set driver options. Patches gladly accepted to fix this.'.format(
          host_machine.system()))
220 221
  endif
endif
222 223 224

with_intel_vk = _vulkan_drivers.contains('intel')
with_amd_vk = _vulkan_drivers.contains('amd')
225
with_freedreno_vk = _vulkan_drivers.contains('freedreno')
226
with_any_vk = _vulkan_drivers.length() != 0 and _vulkan_drivers != ['']
227

228 229 230 231
if with_freedreno_vk and get_option('I-love-half-baked-turnips') != true
  error('Cannot enable freedreno vulkan driver')
endif

Dylan Baker's avatar
Dylan Baker committed
232
if with_dri_swrast and (with_gallium_softpipe or with_gallium_swr)
Dylan Baker's avatar
Dylan Baker committed
233 234
  error('Only one swrast provider can be built')
endif
Dylan Baker's avatar
Dylan Baker committed
235 236 237
if with_dri_i915 and with_gallium_i915
  error('Only one i915 provider can be built')
endif
238
if with_gallium_kmsro and not (with_gallium_v3d or with_gallium_vc4 or with_gallium_etnaviv or with_gallium_freedreno or with_gallium_panfrost or with_gallium_lima)
239
  error('kmsro driver requires one or more renderonly drivers (vc4, etnaviv, freedreno, panfrost, lima)')
240
endif
Thierry Reding's avatar
Thierry Reding committed
241 242 243
if with_gallium_tegra and not with_gallium_nouveau
  error('tegra driver requires nouveau driver')
endif
Dylan Baker's avatar
Dylan Baker committed
244

245 246 247 248
if host_machine.system() == 'darwin'
  with_dri_platform = 'apple'
elif ['windows', 'cygwin'].contains(host_machine.system())
  with_dri_platform = 'windows'
Greg V's avatar
Greg V committed
249
elif system_has_kms_drm
250 251 252 253
  with_dri_platform = 'drm'
else
  # FIXME: haiku doesn't use dri, and xlib doesn't use dri, probably should
  # assert here that one of those cases has been met.
Greg V's avatar
Greg V committed
254
  # FIXME: illumos ends up here as well
255 256
  with_dri_platform = 'none'
endif
Dylan Baker's avatar
Dylan Baker committed
257

258
_platforms = get_option('platforms')
259
if _platforms.contains('auto')
Greg V's avatar
Greg V committed
260
  if system_has_kms_drm
261
    _platforms = ['x11', 'wayland', 'drm', 'surfaceless']
262
  elif ['darwin', 'windows', 'cygwin'].contains(host_machine.system())
263
    _platforms = ['x11', 'surfaceless']
264
  elif ['haiku'].contains(host_machine.system())
265
    _platforms = ['haiku']
266
  else
267 268
    error('Unknown OS @0@. Please pass -Dplatforms to set platforms. Patches gladly accepted to fix this.'.format(
          host_machine.system()))
269 270
  endif
endif
Eric Engestrom's avatar
Eric Engestrom committed
271 272 273 274 275 276 277 278 279 280 281

with_platform_android = _platforms.contains('android')
with_platform_x11 = _platforms.contains('x11')
with_platform_wayland = _platforms.contains('wayland')
with_platform_drm = _platforms.contains('drm')
with_platform_haiku = _platforms.contains('haiku')
with_platform_surfaceless = _platforms.contains('surfaceless')

with_platforms = false
if _platforms.length() != 0 and _platforms != ['']
  with_platforms = true
282
  egl_native_platform = _platforms[0]
283 284
endif

285 286 287 288 289 290 291
_xlib_lease = get_option('xlib-lease')
if _xlib_lease == 'auto'
  with_xlib_lease = with_platform_x11 and with_platform_drm
else
  with_xlib_lease = _xlib_lease == 'true'
endif

292 293 294 295
with_glx = get_option('glx')
if with_glx == 'auto'
  if with_dri
    with_glx = 'dri'
296 297
  elif with_platform_haiku
    with_glx = 'disabled'
298
  elif with_gallium
299 300
    # Even when building just gallium drivers the user probably wants dri
    with_glx = 'dri'
301 302 303 304 305 306 307 308
  elif with_platform_x11 and with_any_opengl and not with_any_vk
    # The automatic behavior should not be to turn on xlib based glx when
    # building only vulkan drivers
    with_glx = 'xlib'
  else
    with_glx = 'disabled'
  endif
endif
309 310 311 312 313
if with_glx == 'dri'
   if with_gallium
      with_dri = true
   endif
endif
314

315
if not (with_dri or with_gallium or with_glx == 'xlib' or with_glx == 'gallium-xlib')
316 317 318 319 320 321 322
  with_gles1 = false
  with_gles2 = false
  with_opengl = false
  with_any_opengl = false
  with_shared_glapi = false
endif

323 324 325
_gbm = get_option('gbm')
if _gbm == 'auto'
  with_gbm = system_has_kms_drm and with_dri
Dylan Baker's avatar
Dylan Baker committed
326
else
327 328 329 330
  with_gbm = _gbm == 'true'
endif
if with_gbm and not system_has_kms_drm
  error('GBM only supports DRM/KMS platforms')
Dylan Baker's avatar
Dylan Baker committed
331 332
endif

Dylan Baker's avatar
Dylan Baker committed
333 334
_egl = get_option('egl')
if _egl == 'auto'
335 336 337 338
  with_egl = (
    not ['darwin', 'windows'].contains(host_machine.system()) and
    with_dri and with_shared_glapi and with_platforms
  )
339
elif _egl == 'true'
Dylan Baker's avatar
Dylan Baker committed
340 341 342 343
  if not with_dri
    error('EGL requires dri')
  elif not with_shared_glapi
    error('EGL requires shared-glapi')
344
  elif not with_platforms
345
    error('No platforms specified, consider -Dplatforms=drm,x11,surfaceless at least')
346 347
  elif not ['disabled', 'dri'].contains(with_glx)
    error('EGL requires dri, but a GLX is being built without dri')
348 349
  elif ['darwin', 'windows'].contains(host_machine.system())
    error('EGL is not available on Windows or MacOS')
Dylan Baker's avatar
Dylan Baker committed
350 351 352 353 354 355
  endif
  with_egl = true
else
  with_egl = false
endif

356
if with_egl and not (with_platform_drm or with_platform_surfaceless or with_platform_android)
Dylan Baker's avatar
Dylan Baker committed
357
  if with_gallium_radeonsi
358
    error('RadeonSI requires the drm, surfaceless or android platform when using EGL')
Dylan Baker's avatar
Dylan Baker committed
359 360
  endif
  if with_gallium_virgl
361
    error('Virgl requires the drm, surfaceless or android platform when using EGL')
Dylan Baker's avatar
Dylan Baker committed
362
  endif
Dylan Baker's avatar
Dylan Baker committed
363 364
endif

365
pre_args += '-DGLX_USE_TLS'
Dylan Baker's avatar
Dylan Baker committed
366
if with_glx != 'disabled'
367
  if not (with_platform_x11 and with_any_opengl)
368
    error('Cannot build GLX support without X11 platform support and at least one OpenGL API')
Dylan Baker's avatar
Dylan Baker committed
369 370 371
  elif with_glx == 'gallium-xlib' 
    if not with_gallium
      error('Gallium-xlib based GLX requires at least one gallium driver')
372 373
    elif not with_gallium_softpipe
      error('Gallium-xlib based GLX requires softpipe or llvmpipe.')
Dylan Baker's avatar
Dylan Baker committed
374 375 376
    elif with_dri
      error('gallium-xlib conflicts with any dri driver')
    endif
377
  elif with_glx == 'xlib' 
Dylan Baker's avatar
Dylan Baker committed
378
    if with_dri
379
      error('xlib conflicts with any dri driver')
Dylan Baker's avatar
Dylan Baker committed
380
    endif
381 382 383 384 385 386
  elif with_glx == 'dri'
    if not with_dri
      error('dri based GLX requires at least one DRI driver')
    elif not with_shared_glapi
      error('dri based GLX requires shared-glapi')
    endif
Dylan Baker's avatar
Dylan Baker committed
387 388 389 390
  endif
endif

with_glvnd = get_option('glvnd')
391 392 393 394 395 396
if with_glvnd
  if with_glx == 'xlib' or with_glx == 'gallium-xlib'
    error('Cannot build glvnd support for GLX that is not DRI based.')
  elif with_glx == 'disabled' and not with_egl
    error('glvnd requires DRI based GLX and/or EGL')
  endif
397 398 399
  if get_option('egl-lib-suffix') != ''
    error('''EGL lib suffix can't be used with libglvnd''')
  endif
Dylan Baker's avatar
Dylan Baker committed
400 401
endif

402 403 404 405
if with_vulkan_icd_dir == ''
  with_vulkan_icd_dir = join_paths(get_option('datadir'), 'vulkan/icd.d')
endif

406 407
with_dri2 = (with_dri or with_any_vk) and (with_dri_platform == 'drm' or
  host_machine.system() == 'gnu')
408 409
_dri3 = get_option('dri3')
if _dri3 == 'auto'
410
  with_dri3 = system_has_kms_drm and with_dri2
411
else
412
  with_dri3 = _dri3 == 'true'
413 414 415 416 417
endif

if with_any_vk and (with_platform_x11 and not with_dri3)
  error('Vulkan drivers require dri3 for X11 support')
endif
418
if with_dri
419 420
  if with_glx == 'disabled' and not with_egl and not with_gbm and with_osmesa != 'classic'
    error('building dri drivers require at least one windowing system or classic osmesa')
Dylan Baker's avatar
Dylan Baker committed
421
  endif
422 423
endif

424 425
prog_pkgconfig = find_program('pkg-config')

426
_vdpau = get_option('gallium-vdpau')
427 428 429
if not system_has_kms_drm
  if _vdpau == 'true'
    error('VDPAU state tracker can only be build on unix-like OSes.')
430
  else
431
    _vdpau = 'false'
432
  endif
433 434
elif not with_platform_x11
  if _vdpau == 'true'
435
    error('VDPAU state tracker requires X11 support.')
436 437 438 439 440 441
  else
    _vdpau = 'false'
  endif
elif not (with_gallium_r300 or with_gallium_r600 or with_gallium_radeonsi or
          with_gallium_nouveau)
  if _vdpau == 'true'
442
    error('VDPAU state tracker requires at least one of the following gallium drivers: r300, r600, radeonsi, nouveau.')
443 444
  else
    _vdpau = 'false'
445 446
  endif
endif
447
dep_vdpau = null_dep
448 449 450 451 452 453 454 455 456
with_gallium_vdpau = false
if _vdpau != 'false'
  dep_vdpau = dependency('vdpau', version : '>= 1.1', required : _vdpau == 'true')
  if dep_vdpau.found()
    dep_vdpau = declare_dependency(
      compile_args : run_command(prog_pkgconfig, ['vdpau', '--cflags']).stdout().split()
    )
    with_gallium_vdpau = true
  endif
457 458 459 460 461 462 463 464 465 466
endif

if with_gallium_vdpau
  pre_args += '-DHAVE_ST_VDPAU'
endif
vdpau_drivers_path = get_option('vdpau-libs-path')
if vdpau_drivers_path == ''
  vdpau_drivers_path = join_paths(get_option('libdir'), 'vdpau')
endif

467
_xvmc = get_option('gallium-xvmc')
468 469 470
if not system_has_kms_drm
  if _xvmc == 'true'
    error('XVMC state tracker can only be build on unix-like OSes.')
471
  else
472
    _xvmc = 'false'
473
  endif
474 475
elif not with_platform_x11
  if _xvmc == 'true'
476
    error('XVMC state tracker requires X11 support.')
477 478 479 480 481
  else
    _xvmc = 'false'
  endif
elif not (with_gallium_r600 or with_gallium_nouveau)
  if _xvmc == 'true'
482
    error('XVMC state tracker requires at least one of the following gallium drivers: r600, nouveau.')
483 484
  else
    _xvmc = 'false'
485 486
  endif
endif
487
dep_xvmc = null_dep
488
with_gallium_xvmc = false
489
if _xvmc != 'false'
490 491
  dep_xvmc = dependency('xvmc', version : '>= 1.0.6', required : _xvmc == 'true')
  with_gallium_xvmc = dep_xvmc.found()
492 493 494 495 496 497 498
endif

xvmc_drivers_path = get_option('xvmc-libs-path')
if xvmc_drivers_path == ''
  xvmc_drivers_path = get_option('libdir')
endif

499
_omx = get_option('gallium-omx')
500
if not system_has_kms_drm
501
  if ['auto', 'disabled'].contains(_omx)
502
    _omx = 'disabled'
503 504
  else
    error('OMX state tracker can only be built on unix-like OSes.')
505
  endif
506
elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
507
  if ['auto', 'disabled'].contains(_omx)
508
    _omx = 'disabled'
509 510
  else
    error('OMX state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau.')
511
  endif
512
endif
513 514
with_gallium_omx = _omx
dep_omx = null_dep
515
dep_omx_other = []
516
if ['auto', 'bellagio'].contains(_omx)
517
  dep_omx = dependency(
518
    'libomxil-bellagio', required : _omx == 'bellagio'
519 520 521 522 523
  )
  if dep_omx.found()
    with_gallium_omx = 'bellagio'
  endif
endif
524 525
if ['auto', 'tizonia'].contains(_omx)
  if with_dri and with_egl
526 527
    dep_omx = dependency(
      'libtizonia', version : '>= 0.10.0',
528
      required : _omx == 'tizonia',
529 530
    )
    dep_omx_other = [
531 532
      dependency('libtizplatform', required : _omx == 'tizonia'),
      dependency('tizilheaders', required : _omx == 'tizonia'),
533 534 535 536
    ]
    if dep_omx.found() and dep_omx_other[0].found() and dep_omx_other[1].found()
      with_gallium_omx = 'tizonia'
    endif
537 538
  elif _omx == 'tizonia'
    error('OMX-Tizonia state tracker requires dri and egl')
539
  endif
540
endif
541 542 543 544 545
if _omx == 'auto'
  with_gallium_omx = 'disabled'
else
  with_gallium_omx = _omx
endif
546

547 548 549 550 551 552
pre_args += [
  '-DENABLE_ST_OMX_BELLAGIO=' + (with_gallium_omx == 'bellagio' ? '1' : '0'),
  '-DENABLE_ST_OMX_TIZONIA=' + (with_gallium_omx == 'tizonia' ? '1' : '0'),
]


553
omx_drivers_path = get_option('omx-libs-path')
554

555
if with_gallium_omx != 'disabled'
556 557 558 559 560 561 562 563 564 565 566 567 568 569 570 571 572 573 574 575 576 577 578
  # Figure out where to put the omx driver.
  # FIXME: this could all be vastly simplified by adding a 'defined_variable'
  # argument to meson's get_pkgconfig_variable method.
  if omx_drivers_path == ''
    _omx_libdir = dep_omx.get_pkgconfig_variable('libdir')
    _omx_drivers_dir = dep_omx.get_pkgconfig_variable('pluginsdir')
    if _omx_libdir == get_option('libdir')
      omx_drivers_path = _omx_drivers_dir
    else
      _omx_base_dir = []
      # This will fail on windows. Does OMX run on windows?
      _omx_libdir = _omx_libdir.split('/')
      _omx_drivers_dir = _omx_drivers_dir.split('/')
      foreach o : _omx_drivers_dir
        if not _omx_libdir.contains(o)
          _omx_base_dir += o
        endif
      endforeach
      omx_drivers_path = join_paths(get_option('libdir'), _omx_base_dir)
    endif
  endif
endif

579
_va = get_option('gallium-va')
580 581 582
if not system_has_kms_drm
  if _va == 'true'
    error('VA state tracker can only be built on unix-like OSes.')
583
  else
584
    _va = 'false'
585
  endif
586 587
elif not (with_gallium_r600 or with_gallium_radeonsi or with_gallium_nouveau)
  if _va == 'true'
588
    error('VA state tracker requires at least one of the following gallium drivers: r600, radeonsi, nouveau.')
589 590
  else
    _va = 'false'
591 592
  endif
endif
593
with_gallium_va = false
594
dep_va = null_dep
595 596 597 598 599 600 601 602
if _va != 'false'
  dep_va = dependency('libva', version : '>= 0.38.0', required : _va == 'true')
  if dep_va.found()
    dep_va_headers = declare_dependency(
      compile_args : run_command(prog_pkgconfig, ['libva', '--cflags']).stdout().split()
    )
    with_gallium_va = true
  endif
603 604 605 606 607 608 609
endif

va_drivers_path = get_option('va-libs-path')
if va_drivers_path == ''
  va_drivers_path = join_paths(get_option('libdir'), 'dri')
endif

610
_xa = get_option('gallium-xa')
611 612 613
if not system_has_kms_drm
  if _xa == 'true'
    error('XA state tracker can only be built on unix-like OSes.')
614
  else
615
    _xa = 'false'
616
  endif
617 618 619
elif not (with_gallium_nouveau or with_gallium_freedreno or with_gallium_i915
          or with_gallium_svga)
  if _xa == 'true'
620
    error('XA state tracker requires at least one of the following gallium drivers: nouveau, freedreno, i915, svga.')
621 622
  else
    _xa = 'false'
623 624
  endif
endif
625
with_gallium_xa = _xa != 'false'
626

627 628
d3d_drivers_path = get_option('d3d-drivers-path')
if d3d_drivers_path == ''
629
  d3d_drivers_path = join_paths(get_option('prefix'), get_option('libdir'), 'd3d')
630 631 632 633 634 635 636
endif

with_gallium_st_nine =  get_option('gallium-nine')
if with_gallium_st_nine
  if not with_gallium_softpipe
    error('The nine state tracker requires gallium softpipe/llvmpipe.')
  elif not (with_gallium_radeonsi or with_gallium_nouveau or with_gallium_r600
637 638
            or with_gallium_r300 or with_gallium_svga or with_gallium_i915
            or with_gallium_iris)
Vinson Lee's avatar
Vinson Lee committed
639
    error('The nine state tracker requires at least one non-swrast gallium driver.')
640 641 642 643 644 645
  endif
  if not with_dri3
    error('Using nine with wine requires dri3')
  endif
endif

646
if get_option('power8') != 'false'
647 648
  # on old versions of meson the cpu family would return as ppc64le on little
  # endian power8, this was changed in 0.48 such that the family would always
649
  # be ppc64 regardless of endianness, and then the machine.endian() value
650 651 652
  # should be checked. Since we support versions < 0.48 we need to use
  # startswith.
  if host_machine.cpu_family().startswith('ppc64') and host_machine.endian() == 'little'
653 654 655 656 657 658 659 660 661 662 663 664 665 666 667 668 669 670 671 672
    if cc.get_id() == 'gcc' and cc.version().version_compare('< 4.8')
      error('Altivec is not supported with gcc version < 4.8.')
    endif
    if cc.compiles('''
        #include <altivec.h>
        int main() {
          vector unsigned char r;
          vector unsigned int v = vec_splat_u32 (1);
          r = __builtin_vec_vgbbd ((vector unsigned char) v);
          return 0;
        }''',
        args : '-mpower8-vector',
        name : 'POWER8 intrinsics')
      pre_args += ['-D_ARCH_PWR8', '-mpower8-vector']
    elif get_option('power8') == 'true'
      error('POWER8 intrinsic support required but not found.')
    endif
  endif
endif

Dylan Baker's avatar
Dylan Baker committed
673
_opencl = get_option('gallium-opencl')
674
clover_cpp_std = []
675
if _opencl != 'disabled'
Dylan Baker's avatar
Dylan Baker committed
676 677 678 679 680 681 682
  if not with_gallium
    error('OpenCL Clover implementation requires at least one gallium driver.')
  endif

  dep_clc = dependency('libclc')
  with_gallium_opencl = true
  with_opencl_icd = _opencl == 'icd'
683 684 685 686 687 688 689 690

  if host_machine.cpu_family().startswith('ppc') and cpp.compiles('''
      #if !defined(__VEC__) || !defined(__ALTIVEC__)
      #error "AltiVec not enabled"
      #endif''',
      name : 'Altivec')
    clover_cpp_std += ['cpp_std=gnu++11']
  endif
Dylan Baker's avatar
Dylan Baker committed
691
else
692
  dep_clc = null_dep
Dylan Baker's avatar
Dylan Baker committed
693
  with_gallium_opencl = false
694
  with_opencl_icd = false
Dylan Baker's avatar
Dylan Baker committed
695 696
endif

Dylan Baker's avatar
Dylan Baker committed
697
gl_pkgconfig_c_flags = []
698
if with_platform_x11
699
  if with_any_vk or with_egl or (with_glx == 'dri' and with_dri_platform == 'drm')
700 701
    pre_args += '-DHAVE_X11_PLATFORM'
  endif
702
  if with_glx == 'xlib' or with_glx == 'gallium-xlib'
703
    pre_args += '-DUSE_XSHM'
704 705 706 707 708 709 710
  else
    pre_args += '-DGLX_INDIRECT_RENDERING'
    if with_glx_direct
      pre_args += '-DGLX_DIRECT_RENDERING'
    endif
    if with_dri_platform == 'drm'
      pre_args += '-DGLX_USE_DRM'
711 712
    elif with_dri_platform == 'apple'
      pre_args += '-DGLX_USE_APPLEGL'
713 714
    elif with_dri_platform == 'windows'
      pre_args += '-DGLX_USE_WINDOWSGL'
715 716
    endif
  endif
Dylan Baker's avatar
Dylan Baker committed
717 718 719 720 721 722 723 724 725 726 727 728
else
  pre_args += '-DMESA_EGL_NO_X11_HEADERS'
  gl_pkgconfig_c_flags += '-DMESA_EGL_NO_X11_HEADERS'
endif
if with_platform_drm
  if with_egl and not with_gbm
    error('EGL drm platform requires gbm')
  endif
  pre_args += '-DHAVE_DRM_PLATFORM'
endif
if with_platform_surfaceless
  pre_args += '-DHAVE_SURFACELESS_PLATFORM'
729
endif
730 731 732 733 734 735
if with_platform_android
  dep_android = [
    dependency('cutils'),
    dependency('hardware'),
    dependency('sync'),
  ]
736 737 738
  if get_option('platform-sdk-version') >= 26
    dep_android += dependency('nativewindow')
  endif
739 740
  pre_args += '-DHAVE_ANDROID_PLATFORM'
endif
741 742 743
if with_platform_haiku
  pre_args += '-DHAVE_HAIKU_PLATFORM'
endif
744

745
prog_python = import('python3').find_python()
746 747 748 749 750 751 752
has_mako = run_command(
  prog_python, '-c',
  '''
from distutils.version import StrictVersion
import mako
assert StrictVersion(mako.__version__) > StrictVersion("0.8.0")
  ''')
753
if has_mako.returncode() != 0
754
  error('Python (3.x) mako module >= 0.8.0 required to build mesa.')
755
endif
756 757

if cc.get_id() == 'gcc' and cc.version().version_compare('< 4.4.6')
758
  error('When using GCC, version 4.4.6 or later is required.')
759 760
endif

761 762
# Define DEBUG for debug builds only (debugoptimized is not included on this one)
if get_option('buildtype') == 'debug'
763 764 765
  pre_args += '-DDEBUG'
endif

766 767 768 769 770 771 772 773 774 775 776 777 778
with_shader_cache = false
_shader_cache = get_option('shader-cache')
if _shader_cache != 'false'
  if host_machine.system() == 'windows'
    if _shader_cache == 'true'
      error('Shader Cache does not currently work on Windows')
    endif
  else
    pre_args += '-DENABLE_SHADER_CACHE'
    with_shader_cache = true
  endif
endif
if with_amd_vk and not with_shader_cache
779 780 781
  error('Radv requires shader cache support')
endif

782 783 784 785 786 787 788 789
# Check for GCC style builtins
foreach b : ['bswap32', 'bswap64', 'clz', 'clzll', 'ctz', 'expect', 'ffs',
             'ffsll', 'popcount', 'popcountll', 'unreachable']
  if cc.has_function(b)
    pre_args += '-DHAVE___BUILTIN_@0@'.format(b.to_upper())
  endif
endforeach

790
# check for GCC __attribute__
791 792 793 794 795 796 797 798 799 800 801 802 803 804 805 806 807
foreach a : ['const', 'flatten', 'malloc', 'pure', 'unused',
             'warn_unused_result', 'weak',]
  if cc.compiles('int foo(void) __attribute__((@0@));'.format(a),
                 name : '__attribute__((@0@))'.format(a))
    pre_args += '-DHAVE_FUNC_ATTRIBUTE_@0@'.format(a.to_upper())
  endif
endforeach
if cc.compiles('int foo(const char *p, ...) __attribute__((format(printf, 1, 2)));',
               name : '__attribute__((format(...)))')
  pre_args += '-DHAVE_FUNC_ATTRIBUTE_FORMAT'
endif
if cc.compiles('struct __attribute__((packed)) foo { int bar; };',
               name : '__attribute__((packed))')
  pre_args += '-DHAVE_FUNC_ATTRIBUTE_PACKED'
endif
if cc.compiles('int *foo(void) __attribute__((returns_nonnull));',
               name : '__attribute__((returns_nonnull))')
808
  pre_args += '-DHAVE_FUNC_ATTRIBUTE_RETURNS_NONNULL'
809 810 811 812 813 814
endif
if cc.compiles('''int foo_def(void) __attribute__((visibility("default")));
                  int foo_hid(void) __attribute__((visibility("hidden")));
                  int foo_int(void) __attribute__((visibility("internal")));
                  int foo_pro(void) __attribute__((visibility("protected")));''',
               name : '__attribute__((visibility(...)))')
815
  pre_args += '-DHAVE_FUNC_ATTRIBUTE_VISIBILITY'
816 817 818 819 820
endif
if cc.compiles('int foo(void) { return 0; } int bar(void) __attribute__((alias("foo")));',
               name : '__attribute__((alias(...)))')
  pre_args += '-DHAVE_FUNC_ATTRIBUTE_ALIAS'
endif
821 822 823 824
if cc.compiles('int foo(void) __attribute__((__noreturn__));',
               name : '__attribute__((__noreturn__))')
  pre_args += '-DHAVE_FUNC_ATTRIBUTE_NORETURN'
endif
825 826 827 828
if cc.compiles('__uint128_t foo(void) { return 0; }',
               name : '__uint128_t')
  pre_args += '-DHAVE_UINT128'
endif
829 830

# TODO: this is very incomplete
831
if ['linux', 'cygwin', 'gnu'].contains(host_machine.system())
832 833 834
  pre_args += '-D_GNU_SOURCE'
endif

835
# Check for generic C arguments
836
c_args = []
Dylan Baker's avatar
Dylan Baker committed
837
foreach a : ['-Werror=implicit-function-declaration',
838
             '-Werror=missing-prototypes', '-Werror=return-type',
839
             '-Werror=incompatible-pointer-types',
840 841
             '-Werror=format',
             '-Wformat-security',
842
             '-fno-math-errno',
843 844 845 846 847
             '-fno-trapping-math', '-Qunused-arguments']
  if cc.has_argument(a)
    c_args += a
  endif
endforeach
848

849
foreach a : ['missing-field-initializers', 'format-truncation']
850 851 852 853
  if cc.has_argument('-W' + a)
    c_args += '-Wno-' + a
  endif
endforeach
854

855 856 857 858 859
c_vis_args = []
if cc.has_argument('-fvisibility=hidden')
  c_vis_args += '-fvisibility=hidden'
endif

860 861
# Check for generic C++ arguments
cpp_args = []
Dylan Baker's avatar
Dylan Baker committed
862
foreach a : ['-Werror=return-type',
863 864
             '-Werror=format',
             '-Wformat-security',
865
             '-fno-math-errno', '-fno-trapping-math',
866 867 868 869 870 871
             '-Qunused-arguments']
  if cpp.has_argument(a)
    cpp_args += a
  endif
endforeach

872 873
# For some reason, the test for -Wno-foo always succeeds with gcc, even if the
# option is not supported. Hence, check for -Wfoo instead.
874

875
foreach a : ['non-virtual-dtor', 'missing-field-initializers', 'format-truncation']
876 877 878 879
  if cpp.has_argument('-W' + a)
    cpp_args += '-Wno-' + a
  endif
endforeach
880 881 882 883 884 885 886 887

no_override_init_args = []
foreach a : ['override-init', 'initializer-overrides']
  if cc.has_argument('-W' + a)
    no_override_init_args += '-Wno-' + a
  endif
endforeach

888 889 890 891 892 893 894 895 896 897 898 899 900 901 902 903 904 905 906
cpp_vis_args = []
if cpp.has_argument('-fvisibility=hidden')
  cpp_vis_args += '-fvisibility=hidden'
endif

# Check for C and C++ arguments for MSVC2013 compatibility. These are only used
# in parts of the mesa code base that need to compile with old versions of
# MSVC, mainly common code
c_msvc_compat_args = []
cpp_msvc_compat_args = []
foreach a : ['-Werror=pointer-arith', '-Werror=vla']
  if cc.has_argument(a)
    c_msvc_compat_args += a
  endif
  if cpp.has_argument(a)
    cpp_msvc_compat_args += a
  endif
endforeach

907
if host_machine.cpu_family().startswith('x86')
908
  pre_args += '-DUSE_SSE41'
909 910 911 912 913 914 915 916 917 918 919 920
  with_sse41 = true
  sse41_args = ['-msse4.1']

  # GCC on x86 (not x86_64) with -msse* assumes a 16 byte aligned stack, but
  # that's not guaranteed
  if host_machine.cpu_family() == 'x86'
    sse41_args += '-mstackrealign'
  endif
else
  with_sse41 = false
  sse41_args = []
endif
921 922

# Check for GCC style atomics
923
dep_atomic = null_dep
924

Matt Turner's avatar
Matt Turner committed
925 926 927 928 929
if cc.compiles('''#include <stdint.h>
                  int main() {
                    struct {
                      uint64_t *v;
                    } x;
930 931 932
                    return (int)__atomic_load_n(x.v, __ATOMIC_ACQUIRE) &
                           (int)__atomic_add_fetch(x.v, (uint64_t)1, __ATOMIC_ACQ_REL);

Matt Turner's avatar
Matt Turner committed
933
                  }''',
934 935
               name : 'GCC atomic builtins')
  pre_args += '-DUSE_GCC_ATOMIC_BUILTINS'
936 937 938 939 940 941 942 943 944

  # Not all atomic calls can be turned into lock-free instructions, in which
  # GCC will make calls into the libatomic library. Check whether we need to
  # link with -latomic.
  #
  # This can happen for 64-bit atomic operations on 32-bit architectures such
  # as ARM.
  if not cc.links('''#include <stdint.h>
                     int main() {
945 946 947
                       struct {
                         uint64_t *v;
                       } x;
948 949
                       return (int)__atomic_load_n(x.v, __ATOMIC_ACQUIRE) &
                              (int)__atomic_add_fetch(x.v, (uint64_t)1, __ATOMIC_ACQ_REL);
950 951 952 953
                     }''',
                  name : 'GCC atomic builtins required -latomic')
    dep_atomic = cc.find_library('atomic')
  endif
954 955 956 957 958 959
endif
if not cc.links('''#include <stdint.h>
                   uint64_t v;
                   int main() {
                     return __sync_add_and_fetch(&v, (uint64_t)1);
                   }''',
Dylan Baker's avatar
Dylan Baker committed
960
                dependencies : dep_atomic,
961
                name : 'GCC 64bit atomics')
Dylan Baker's avatar
Dylan Baker committed
962
  pre_args += '-DMISSING_64BIT_ATOMICS'
963 964 965 966
endif

# TODO: shared/static? Is this even worth doing?

967 968 969 970 971 972
# When cross compiling we generally need to turn off the use of assembly,
# because mesa's assembly relies on building an executable for the host system,
# and running it to get information about struct sizes. There is at least one
# case of cross compiling where we can use asm, and that's x86_64 -> x86 when
# host OS == build OS, since in that case the build machine can run the host's
# binaries.
973
if with_asm and meson.is_cross_build()
974 975 976 977
  if build_machine.system() != host_machine.system()
    # TODO: It may be possible to do this with an exe_wrapper (like wine).
    message('Cross compiling from one OS to another, disabling assembly.')
    with_asm = false
978 979 980 981
  elif not (build_machine.cpu_family().startswith('x86') and host_machine.cpu_family() == 'x86')
    # FIXME: Gentoo always sets -m32 for x86_64 -> x86 builds, resulting in an
    # x86 -> x86 cross compile. We use startswith rather than == to handle this
    # case.
982 983 984 985 986 987
    # TODO: There may be other cases where the 64 bit version of the
    # architecture can run 32 bit binaries (aarch64 and armv7 for example)
    message('''
      Cross compiling to different architectures, and the host cannot run
      the build machine's binaries. Disabling assembly.
    ''')
988 989
    with_asm = false
  endif
990 991 992 993 994
endif

with_asm_arch = ''
if with_asm
  if host_machine.cpu_family() == 'x86'
995
    if system_has_kms_drm or host_machine.system() == 'gnu'
996 997 998
      with_asm_arch = 'x86'
      pre_args += ['-DUSE_X86_ASM', '-DUSE_MMX_ASM', '-DUSE_3DNOW_ASM',
                   '-DUSE_SSE_ASM']
999 1000 1001 1002

      if with_glx_read_only_text
         pre_args += ['-DGLX_X86_READONLY_TEXT']
      endif
1003 1004
    endif
  elif host_machine.cpu_family() == 'x86_64'
Greg V's avatar
Greg V committed
1005
    if system_has_kms_drm
1006 1007 1008 1009
      with_asm_arch = 'x86_64'
      pre_args += ['-DUSE_X86_64_ASM']
    endif
  elif host_machine.cpu_family() == 'arm'
Greg V's avatar
Greg V committed
1010
    if system_has_kms_drm
1011 1012 1013 1014
      with_asm_arch = 'arm'
      pre_args += ['-DUSE_ARM_ASM']
    endif
  elif host_machine.cpu_family() == 'aarch64'
Greg V's avatar
Greg V committed
1015
    if system_has_kms_drm
1016 1017 1018
      with_asm_arch = 'aarch64'
      pre_args += ['-DUSE_AARCH64_ASM']
    endif
1019 1020 1021 1022 1023
  elif host_machine.cpu_family() == 'sparc64'
    if system_has_kms_drm
      with_asm_arch = 'sparc'
      pre_args += ['-DUSE_SPARC_ASM']
    endif
1024
  elif host_machine.cpu_family().startswith('ppc64') and host_machine.endian() == 'little'
1025 1026 1027 1028
    if system_has_kms_drm
      with_asm_arch = 'ppc64le'
      pre_args += ['-DUSE_PPC64LE_ASM']
    endif
1029 1030
  endif
endif
1031 1032 1033 1034 1035 1036 1037 1038

# Check for standard headers and functions
if cc.has_header_symbol('sys/sysmacros.h', 'major')
  pre_args += '-DMAJOR_IN_SYSMACROS'
elif cc.has_header_symbol('sys/mkdev.h', 'major')
  pre_args += '-DMAJOR_IN_MKDEV'
endif

1039
foreach h : ['xlocale.h', 'sys/sysctl.h', 'linux/futex.h', 'endian.h', 'dlfcn.h', 'execinfo.h']
1040
  if cc.compiles('#include <@0@>'.format(h), name : '@0@'.format(h))
1041 1042 1043 1044
    pre_args += '-DHAVE_@0@'.format(h.to_upper().underscorify())
  endif
endforeach

1045
foreach f : ['strtof', 'mkostemp', 'posix_memalign', 'timespec_get', 'memfd_create']
1046 1047 1048 1049 1050 1051 1052 1053 1054 1055 1056 1057 1058 1059 1060 1061 1062 1063
  if cc.has_function(f)
    pre_args += '-DHAVE_@0@'.format(f.to_upper())
  endif
endforeach

# strtod locale support
if cc.links('''
    #define _GNU_SOURCE
    #include <stdlib.h>
    #include <locale.h>
    #ifdef HAVE_XLOCALE_H
    #include <xlocale.h>
    #endif
    int main() {
      locale_t loc = newlocale(LC_CTYPE_MASK, "C", NULL);
      const char *s = "1.0";
      char *end;
      double d = strtod_l(s, end, loc);
1064
      float f = strtof_l(s, end, loc);
1065 1066 1067
      freelocale(loc);
      return 0;
    }''',
1068
    args : pre_args,
1069 1070 1071 1072 1073 1074
    name : 'strtod has locale support')
  pre_args += '-DHAVE_STRTOD_L'
endif

# Check for some linker flags
ld_args_bsymbolic = []
1075
if cc.links('int main() { return 0; }', args : '-Wl,-Bsymbolic', name : 'Bsymbolic')
1076 1077 1078 1079
  ld_args_bsymbolic += '-Wl,-Bsymbolic'
endif
ld_args_gc_sections = []
if cc.links('static char unused() { return 5; } int main() { return 0; }',
1080
            args : '-Wl,--gc-sections', name : 'gc-sections')
1081 1082
  ld_args_gc_sections += '-Wl,--gc-sections'
endif
1083 1084 1085 1086 1087 1088 1089 1090 1091 1092 1093 1094 1095 1096
with_ld_version_script = false
if cc.links('int main() { return 0; }',
            args : '-Wl,--version-script=@0@'.format(
              join_paths(meson.source_root(), 'build-support/conftest.map')),
            name : 'version-script')
  with_ld_version_script = true
endif
with_ld_dynamic_list = false
if cc.links('int main() { return 0; }',
            args : '-Wl,--dynamic-list=@0@'.format(
              join_paths(meson.source_root(), 'build-support/conftest.dyn')),
            name : 'dynamic-list')
  with_ld_dynamic_list = true
endif
1097 1098 1099 1100
ld_args_build_id = []
if build_machine.system() != 'darwin'
   ld_args_build_id += '-Wl,--build-id=sha1'
endif
1101 1102 1103

# check for dl support
if cc.has_function('dlopen')
1104
  dep_dl = null_dep
1105 1106 1107
else
  dep_dl = cc.find_library('dl')
endif
1108 1109 1110
if cc.has_function('dladdr', dependencies : dep_dl)
  # This is really only required for megadrivers
  pre_args += '-DHAVE_DLADDR'
1111 1112 1113 1114
endif

if cc.has_function('dl_iterate_phdr')
  pre_args += '-DHAVE_DL_ITERATE_PHDR'
1115 1116
elif with_intel_vk
  error('Intel "Anvil" Vulkan driver requires the dl_iterate_phdr function')
1117
elif with_dri_i965 and with_shader_cache
1118
  error('Intel i965 GL driver requires dl_iterate_phdr when built with shader caching.')
1119 1120 1121 1122
endif

# Determine whether or not the rt library is needed for time functions
if cc.has_function('clock_gettime')
1123
  dep_clock = null_dep
1124 1125 1126 1127 1128 1129
else
  dep_clock = cc.find_library('rt')
endif

# TODO: some of these may be conditional
dep_zlib = dependency('zlib', version : '>= 1.2.3')
1130
pre_args += '-DHAVE_ZLIB'
1131
dep_thread = dependency('threads')
1132
if dep_thread.found() and host_machine.system() != 'windows'
1133
  pre_args += '-DHAVE_PTHREAD'
1134 1135 1136 1137 1138 1139 1140
  if cc.has_function(
      'pthread_setaffinity_np',
      dependencies : dep_thread,
      prefix : '#include <pthread.h>',
      args : '-D_GNU_SOURCE')
    pre_args += '-DHAVE_PTHREAD_SETAFFINITY'
  endif
1141
endif
1142 1143
dep_expat = dependency('expat')
# this only exists on linux so either this is linux and it will be found, or
1144
# it's not linux and wont
1145
dep_m = cc.find_library('m', required : false)
Dylan Baker's avatar
Dylan Baker committed
1146

1147
# Check for libdrm. Various drivers have different libdrm version requirements,
1148 1149 1150
# but we always want to use the same version for all libdrm modules. That means
# even if driver foo requires 2.4.0 and driver bar requires 2.4.3, if foo and
# bar are both on use 2.4.3 for both of them
1151 1152 1153 1154
dep_libdrm_amdgpu = null_dep
dep_libdrm_radeon = null_dep
dep_libdrm_nouveau = null_dep
dep_libdrm_intel = null_dep
1155

1156
_drm_amdgpu_ver = '2.4.97'
1157 1158 1159 1160 1161 1162 1163 1164 1165 1166 1167 1168 1169
_drm_radeon_ver = '2.4.71'
_drm_nouveau_ver = '2.4.66'
_drm_intel_ver = '2.4.75'
_drm_ver = '2.4.75'

_libdrm_checks = [
  ['intel', with_dri_i915 or with_gallium_i915],
  ['amdgpu', with_amd_vk or with_gallium_radeonsi],
  ['radeon', (with_gallium_radeonsi or with_dri_r100 or with_dri_r200 or
              with_gallium_r300 or with_gallium_r600)],
  ['nouveau', (with_gallium_nouveau or with_dri_nouveau)],
]

1170 1171 1172 1173 1174 1175
# VC4 only needs core libdrm support of this version, not a libdrm_vc4
# library.
if with_gallium_vc4
  _drm_ver = '2.4.89'
endif

1176 1177 1178 1179 1180
# etnaviv only needs core libdrm
if with_gallium_etnaviv
  _drm_ver = '2.4.89'
endif

1181 1182
# Loop over the enables versions and get the highest libdrm requirement for all
# active drivers.
1183
_drm_blame = ''
1184 1185 1186 1187
foreach d : _libdrm_checks
  ver = get_variable('_drm_@0@_ver'.format(d[0]))
  if d[1] and ver.version_compare('>' + _drm_ver)
    _drm_ver = ver
1188
    _drm_blame = d[0]
1189 1190
  endif
endforeach
1191 1192 1193
if _drm_blame != ''
  message('libdrm @0@ needed because @1@ has the highest requirement'.format(_drm_ver, _drm_blame))
endif
1194 1195 1196 1197 1198 1199

# Then get each libdrm module
foreach d : _libdrm_checks
  if d[1]
    set_variable(
      'dep_libdrm_' + d[0],
1200
      dependency('libdrm_' + d[0], version : '>=' + _drm_ver)
1201 1202 1203
    )
  endif
endforeach
1204

1205
with_gallium_drisw_kms = false
1206 1207
dep_libdrm = dependency(
  'libdrm', version : '>=' + _drm_ver,
1208
  required : with_dri2 or with_dri3
1209
)
1210 1211 1212 1213 1214 1215 1216
if dep_libdrm.found()
  pre_args += '-DHAVE_LIBDRM'
  if with_dri_platform == 'drm' and with_dri
    with_gallium_drisw_kms = true
  endif
endif

1217
llvm_modules = ['bitwriter', 'engine', 'mcdisassembler', 'mcjit']
1218
llvm_optional_modules = []
Dylan Baker's avatar
Dylan Baker committed
1219
if with_amd_vk or with_gallium_radeonsi or with_gallium_r600
1220
  llvm_modules += ['amdgpu', 'native', 'bitreader', 'ipo']
Dylan Baker's avatar
Dylan Baker committed
1221 1222 1223
  if with_gallium_r600
    llvm_modules += 'asmparser'
  endif
1224
endif
Dylan Baker's avatar
Dylan Baker committed
1225 1226 1227 1228 1229
if with_gallium_opencl
  llvm_modules += [
    'all-targets', 'linker', 'coverage', 'instrumentation', 'ipo', 'irreader',
    'lto', 'option', 'objcarcopts', 'profiledata',
  ]
1230
  llvm_optional_modules += ['coroutines']
Dylan Baker's avatar
Dylan Baker committed
1231
endif
1232

1233
if with_amd_vk or with_gallium_radeonsi
1234
  _llvm_version = '>= 7.0.0'
1235
elif with_gallium_swr
1236
  _llvm_version = '>= 6.0.0'
1237
elif with_gallium_opencl or with_gallium_r600
1238 1239 1240 1241 1242
  _llvm_version = '>= 3.9.0'
else
  _llvm_version = '>= 3.3.0'
endif

1243 1244
_shared_llvm = get_option('shared-llvm')

1245
_llvm = get_option('llvm')
1246 1247 1248
dep_llvm = null_dep
with_llvm = false
if _llvm != 'false'
1249 1250 1251 1252 1253
  dep_llvm = dependency(
    'llvm',
    version : _llvm_version,
    modules : llvm_modules,
    optional_modules : llvm_optional_modules,
1254 1255 1256 1257
    required : (
      with_amd_vk or with_gallium_radeonsi or with_gallium_swr or
      with_gallium_opencl or _llvm == 'true'
    ),
1258
    static : not _shared_llvm,
1259
    method : 'config-tool',
1260
  )
1261
  with_llvm = dep_llvm.found()
1262 1263 1264 1265
endif
if with_llvm
  _llvm_version = dep_llvm.version().split('.')
  pre_args += [
1266
    '-DHAVE_LLVM=0x0@0@0@1@'.format(_llvm_version[0], _llvm_version[1]),
1267
    '-DMESA_LLVM_VERSION_STRING="@0@"'.format(dep_llvm.version()),
1268
  ]
1269 1270 1271 1272 1273

  # LLVM can be built without rtti, turning off rtti changes the ABI of C++
  # programs, so we need to build all C++ code in mesa without rtti as well to
  # ensure that linking works.
  if dep_llvm.get_configtool_variable('has-rtti') == 'NO'
1274 1275
    if with_gallium_nouveau
      error('The Nouveau driver requires rtti. You either need to turn off nouveau or use an LLVM built with LLVM_ENABLE_RTTI.')
1276 1277
    elif with_gallium_opencl
      error('The Clover OpenCL state tracker requires rtti, you need to turn off clover or use an LLVM built with LLVM_ENABLE_RTTI.')
1278
    endif
1279
    cpp_args += '-fno-rtti'
1280
  endif
Dylan Baker's avatar
Dylan Baker committed
1281
elif with_amd_vk or with_gallium_radeonsi or with_gallium_swr
1282
  error('The following drivers require LLVM: Radv, RadeonSI, SWR. One of these is enabled, but LLVM is disabled.')
1283 1284
elif with_gallium_opencl
  error('The OpenCL "Clover" state tracker requires LLVM, but LLVM is disabled.')
1285
endif
1286

1287 1288 1289 1290 1291 1292 1293 1294 1295 1296
if (with_amd_vk or with_gallium_radeonsi or with_gallium_opencl or
    (with_gallium_r600 and with_llvm))
  dep_elf = dependency('libelf', required : false)
  if not dep_elf.found()
    dep_elf = cc.find_library('elf')
  endif
else
  dep_elf = null_dep
endif

1297
dep_glvnd = null_dep
Dylan Baker's avatar
Dylan Baker committed
1298 1299 1300 1301 1302
if with_glvnd
  dep_glvnd = dependency('libglvnd', version : '>= 0.2.0')
  pre_args += '-DUSE_LIBGLVND=1'
endif

1303 1304 1305 1306 1307 1308
if with_valgrind != 'false'
  dep_valgrind = dependency('valgrind', required : with_valgrind == 'true')
  if dep_valgrind.found()
    pre_args += '-DHAVE_VALGRIND'
  endif
else
1309
  dep_valgrind = null_dep
1310 1311 1312 1313
endif

# pthread stubs. Lets not and say we didn't

1314 1315 1316
prog_bison = find_program('bison', required : with_any_opengl)
prog_flex = find_program('flex', required : with_any_opengl)

1317
dep_selinux = null_dep
Eric Engestrom's avatar
Eric Engestrom committed
1318 1319 1320 1321
if get_option('selinux')
  dep_selinux = dependency('libselinux')
  pre_args += '-DMESA_SELINUX'
endif
1322

1323 1324 1325 1326 1327 1328
if with_libunwind != 'false'
  dep_unwind = dependency('libunwind', required : with_libunwind == 'true')
  if dep_unwind.found()
    pre_args += '-DHAVE_LIBUNWIND'
  endif
else
1329
  dep_unwind = null_dep
1330
endif
1331

1332 1333 1334 1335
if with_osmesa != 'none'
  if with_osmesa == 'classic' and not with_dri_swrast
    error('OSMesa classic requires dri (classic) swrast.')
  endif
1336 1337 1338
  if with_osmesa == 'gallium' and not with_gallium_softpipe
    error('OSMesa gallium requires gallium softpipe or llvmpipe.')
  endif
1339 1340 1341 1342 1343 1344 1345 1346 1347 1348 1349 1350
  osmesa_lib_name = 'OSMesa'
  osmesa_bits = get_option('osmesa-bits')
  if osmesa_bits != '8'
    if with_dri or with_glx != 'disabled'
      error('OSMesa bits must be 8 if building glx or dir based drivers')
    endif
    osmesa_lib_name = osmesa_lib_name + osmesa_bits
    pre_args += [
      '-DCHAN_BITS=@0@'.format(osmesa_bits), '-DDEFAULT_SOFTWARE_DEPTH_BITS=31'
    ]
  endif
endif
1351 1352 1353 1354

# TODO: symbol mangling

if with_platform_wayland
1355 1356
  dep_wl_scanner = dependency('wayland-scanner', native: true)
  prog_wl_scanner = find_program(dep_wl_scanner.get_pkgconfig_variable('wayland_scanner'))
1357 1358 1359 1360 1361
  if dep_wl_scanner.version().version_compare('>= 1.15')
    wl_scanner_arg = 'private-code'
  else
    wl_scanner_arg = 'code'
  endif
1362 1363 1364
  dep_wl_protocols = dependency('wayland-protocols', version : '>= 1.8')
  dep_wayland_client = dependency('wayland-client', version : '>=1.11')
  dep_wayland_server = dependency('wayland-server', version : '>=1.11')
1365
  if with_egl
1366 1367 1368
    dep_wayland_egl = dependency('wayland-egl-backend', version : '>= 3')
    dep_wayland_egl_headers = declare_dependency(
      compile_args : run_command(prog_pkgconfig, ['wayland-egl-backend', '--cflags']).stdout().split())
1369
  endif
Dylan Baker's avatar
Dylan Baker committed
1370 1371 1372 1373 1374
  wayland_dmabuf_xml = join_paths(
    dep_wl_protocols.get_pkgconfig_variable('pkgdatadir'), 'unstable',
    'linux-dmabuf', 'linux-dmabuf-unstable-v1.xml'
  )
  pre_args += ['-DHAVE_WAYLAND_PLATFORM', '-DWL_HIDE_DEPRECATED']
1375 1376
endif

1377 1378 1379 1380 1381 1382 1383 1384 1385 1386 1387 1388 1389 1390 1391 1392 1393
dep_x11 = null_dep
dep_xext = null_dep
dep_xdamage = null_dep
dep_xfixes = null_dep
dep_x11_xcb = null_dep
dep_xcb = null_dep
dep_xcb_glx = null_dep
dep_xcb_dri2 = null_dep
dep_xcb_dri3 = null_dep
dep_dri2proto = null_dep
dep_glproto = null_dep
dep_xxf86vm = null_dep
dep_xcb_dri3 = null_dep
dep_xcb_present = null_dep
dep_xcb_sync = null_dep
dep_xcb_xfixes = null_dep
dep_xshmfence = null_dep
1394
dep_xcb_xrandr = null_dep
1395
dep_xlib_xrandr = null_dep
1396
if with_platform_x11
1397
  if with_glx == 'xlib' or with_glx == 'gallium-xlib'
1398 1399 1400
    dep_x11 = dependency('x11')
    dep_xext = dependency('xext')
    dep_xcb = dependency('xcb')
1401
  elif with_glx == 'dri'
1402 1403 1404 1405 1406
    dep_x11 = dependency('x11')
    dep_xext = dependency('xext')
    dep_xdamage = dependency('xdamage', version : '>= 1.1')
    dep_xfixes = dependency('xfixes')
    dep_xcb_glx = dependency('xcb-glx', version : '>= 1.8.1')
Dylan Baker's avatar
Dylan Baker committed
1407
  endif
1408
  if (with_any_vk or with_glx == 'dri' or with_egl or
1409 1410
       (with_gallium_vdpau or with_gallium_xvmc or with_gallium_va or
        with_gallium_omx != 'disabled'))
1411 1412
    dep_xcb = dependency('xcb')
    dep_x11_xcb = dependency('x11-xcb')
1413
  endif
1414
  if with_any_vk or with_egl or (with_glx == 'dri' and with_dri_platform == 'drm')
1415 1416
    dep_xcb_dri2 = dependency('xcb-dri2', version : '>= 1.8')

Dylan Baker's avatar
Dylan Baker committed
1417
    if with_dri3
1418 1419 1420 1421 1422 1423 1424 1425
      pre_args += '-DHAVE_DRI3'
      dep_xcb_dri3 = dependency('xcb-dri3')
      dep_xcb_present = dependency('xcb-present')
      # until xcb-dri3 has been around long enough to make a hard-dependency:
      if (dep_xcb_dri3.version().version_compare('>= 1.13') and
          dep_xcb_present.version().version_compare('>= 1.13'))
        pre_args += '-DHAVE_DRI3_MODIFIERS'
      endif
1426 1427
      dep_xcb_sync = dependency('xcb-sync')
      dep_xshmfence = dependency('xshmfence', version : '>= 1.1')
Dylan Baker's avatar
Dylan Baker committed
1428
    endif
1429
  endif
1430 1431 1432 1433
  if with_glx == 'dri' or with_glx == 'gallium-xlib'
    dep_glproto = dependency('glproto', version : '>= 1.4.14')
  endif
  if with_glx == 'dri' 
1434 1435
    if with_dri_platform == 'drm'
      dep_dri2proto = dependency('dri2proto', version : '>= 2.8')
1436
      dep_xxf86vm = dependency('xxf86vm')
1437
    endif
1438
  endif
1439 1440 1441
  if (with_egl or (
      with_gallium_vdpau or with_gallium_xvmc or with_gallium_xa or
      with_gallium_omx != 'disabled'))
Dylan Baker's avatar
Dylan Baker committed
1442 1443
    dep_xcb_xfixes = dependency('xcb-xfixes')
  endif
1444
  if with_xlib_lease
1445
    dep_xcb_xrandr = dependency('xcb-randr')
1446
    dep_xlib_xrandr = dependency('xrandr', version : '>= 1.3')
1447
  endif
1448 1449
endif

1450 1451 1452 1453
if get_option('gallium-extra-hud')
  pre_args += '-DHAVE_GALLIUM_EXTRA_HUD=1'
endif

1454 1455
_sensors = get_option('lmsensors')
if _sensors != 'false'
1456
  dep_lmsensors = cc.find_library('sensors', required : _sensors == 'true')
1457 1458 1459 1460
  if dep_lmsensors.found()
    pre_args += '-DHAVE_LIBSENSORS=1'
  endif
else
1461
  dep_lmsensors = null_dep
1462 1463
endif

1464 1465 1466 1467 1468 1469 1470 1471 1472 1473
foreach a : pre_args
  add_project_arguments(a, language : ['c', 'cpp'])
endforeach
foreach a : c_args
  add_project_arguments(a, language : ['c'])
endforeach
foreach a : cpp_args
  add_project_arguments(a, language : ['cpp'])
endforeach

1474 1475 1476 1477 1478 1479 1480 1481 1482 1483
gl_priv_reqs = []

if with_glx == 'xlib' or with_glx == 'gallium-xlib'
  gl_priv_reqs += ['x11', 'xext', 'xcb']
elif with_glx == 'dri'
  gl_priv_reqs += [
    'x11', 'xext', 'xdamage >= 1.1', 'xfixes', 'x11-xcb', 'xcb',
    'xcb-glx >= 1.8.1']
  if with_dri_platform == 'drm'
    gl_priv_reqs += 'xcb-dri2 >= 1.8'
1484
    gl_priv_reqs += 'xxf86vm'
1485 1486
  endif
endif
1487 1488 1489
if dep_libdrm.found()
  gl_priv_reqs += 'libdrm >= 2.4.75'
endif
Dylan Baker's avatar
Dylan Baker committed
1490 1491 1492 1493 1494 1495 1496 1497

gl_priv_libs = []
if dep_thread.found()
  gl_priv_libs += ['-lpthread', '-pthread']
endif
if dep_m.found()
  gl_priv_libs += '-lm'
endif
1498
if dep_dl.found()
Dylan Baker's avatar
Dylan Baker committed
1499 1500 1501
  gl_priv_libs += '-ldl'
endif

1502 1503
pkg = import('pkgconfig')

1504
prog_nm = find_program('nm', required : false)
1505
env_test = environment()
1506 1507 1508
if prog_nm.found()
  env_test.set('NM', prog_nm.path())
endif
1509