Commit 5872850b authored by Emil Velikov's avatar Emil Velikov Committed by Emil Velikov

configure.ac: move require_dri_shared_libs_and_glapi() before its users

Otherwise we'll get a lovely message as below:
"require_dri_shared_libs_and_glapi: command not found"

Cc: Steven Newbury <steve@snewbury.org.uk>
Reported-by: default avatarSteven Newbury <steve@snewbury.org.uk>
Fixes: da410e6a "configure: explicitly require shared glapi for
enable-dri"
Signed-off-by: default avatarEmil Velikov <emil.l.velikov@gmail.com>
Tested-by: default avatarSteven Newbury <steve@snewbury.org.uk>
Reviewed-by: default avatarNicolai Hähnle <nicolai.haehnle@amd.com>
parent 383fc8e9
......@@ -1436,6 +1436,22 @@ if test "x$enable_gallium_osmesa" = xyes; then
fi
fi
require_dri_shared_libs_and_glapi() {
if test "x$enable_static" = xyes; then
AC_MSG_ERROR([$1 cannot be build as static library])
fi
if test "x$enable_dri" != xyes; then
# There is only a single backend which won't be build/used otherwise.
# XXX: Revisit this as the egl/haiku is a thing.
AC_MSG_ERROR([$1 requires --enable-dri])
fi
if test "x$enable_shared_glapi" != xyes; then
AC_MSG_ERROR([$1 requires --enable-shared-glapi])
fi
}
if test "x$enable_dri" = xyes; then
require_dri_shared_libs_and_glapi "DRI"
......@@ -1815,22 +1831,6 @@ AC_SUBST([OSMESA_LIB_DEPS])
AC_SUBST([OSMESA_PC_REQ])
AC_SUBST([OSMESA_PC_LIB_PRIV])
require_dri_shared_libs_and_glapi() {
if test "x$enable_static" = xyes; then
AC_MSG_ERROR([$1 cannot be build as static library])
fi
if test "x$enable_dri" != xyes; then
# There is only a single backend which won't be build/used otherwise.
# XXX: Revisit this as the egl/haiku is a thing.
AC_MSG_ERROR([$1 requires --enable-dri])
fi
if test "x$enable_shared_glapi" != xyes; then
AC_MSG_ERROR([$1 requires --enable-shared-glapi])
fi
}
dnl
dnl gbm configuration
dnl
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment