Commit 795488d2 authored by Eric Anholt's avatar Eric Anholt

v3d: Enable the driver by default.

Now that we have a stabilized ABI and a fairly conformant driver, turn it
on.
parent 01ae6a91
......@@ -2740,7 +2740,7 @@ if test -n "$with_gallium_drivers"; then
PKG_CHECK_MODULES([V3D_SIMULATOR], [v3dv3],
[USE_V3D_SIMULATOR=yes;
DEFINES="$DEFINES -DUSE_V3D_SIMULATOR"],
[AC_MSG_ERROR([vc5 requires the simulator])])
[USE_V3D_SIMULATOR=no])
;;
xpl111)
HAVE_GALLIUM_PL111=yes
......
......@@ -53,7 +53,7 @@ files_per_version = files(
)
v3dv3_c_args = []
dep_v3dv3 = dependency('v3dv3')
dep_v3dv3 = dependency('v3dv3', required: false)
if dep_v3dv3.found()
v3dv3_c_args = '-DUSE_V3D_SIMULATOR'
endif
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment