Commit 31e51438 authored by Simon McVittie's avatar Simon McVittie Committed by Vivek Das Mohapatra

Skip GLib tests when GLib is older than 2.38

GLib 2.38 was the first stable release with TAP output support, and
our unit test relies on that.
Signed-off-by: Simon McVittie's avatarSimon McVittie <smcv@collabora.com>
parent b8a33cd3
......@@ -78,7 +78,7 @@ AC_ARG_WITH([glib],
[],
[with_glib=auto])
AS_IF([test "$with_glib" != no],
[PKG_CHECK_MODULES([GLIB], [glib-2.0], [have_glib=yes], [have_glib=no])],
[PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.38], [have_glib=yes], [have_glib=no])],
[have_glib=no])
AS_IF([test "$with_glib" = yes && test "$have_glib" = no],
[AC_MSG_ERROR([GLib required but not found])])
......
......@@ -23,7 +23,7 @@ confflags += --disable-gtk-doc
endif
ifeq ($(DEB_HOST_ARCH),amd64)
confflags += --with-glib
confflags += --with-glib=auto
else
confflags += --without-glib
endif
......
......@@ -145,9 +145,7 @@ main (int argc,
char **argv)
{
g_test_init (&argc, &argv, NULL);
#if GLIB_CHECK_VERSION(2, 38, 0)
g_test_set_nonfatal_assertions ();
#endif
g_test_add ("/build-filename", Fixture, NULL, setup,
test_build_filename, teardown);
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment